Opened 9 years ago

Closed 9 years ago

#8599 closed defect (duplicate)

MythWeb not showing number of episodes recorded in dropdown list.

Reported by: MarcT <myrdhn@…> Owned by: Rob Smith
Priority: trivial Milestone: unknown
Component: Plugin - MythWeb Version: Master Head
Severity: low Keywords:
Cc: Ticket locked: no

Description

I just noticed this today. In MythWeb, on the Recorded Programs page, in the Show Recordings dropdown list, you no longer see the number of episodes recorded for a show. However, it still knows if there is more than 1.

For example:
A single episode would only show "The Mentalist", this still works.
Multiple episodes should say "The Mentalist (2)", currently you get "The Mentalist ()"

Attachments (1)

Show Recordings.png (12.1 KB) - added by MarcT <myrdhn@…> 9 years ago.
Screenshot of issue, currently running myth and all plugins from 25163

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by MarcT <myrdhn@…>

Attachment: Show Recordings.png added

Screenshot of issue, currently running myth and all plugins from 25163

comment:1 Changed 9 years ago by Jim Stichnoth <stichnot@…>

Some additional observations likely related to the reported problem:

  1. "Length" column in /mythweb/tv/recorded is always empty.
  1. "Record Length" column in /mythweb/tv/upcoming is always empty.
  1. If /mythweb/tv/upcoming is repeated reloaded, it alternates between a normal state (except for item 2 above) and a state where the "Record Date" and "Record Length" columns are always empty and the date separator rows are missing.

(Note: I am running with PHP 5.2.9 with the mythweb workaround referenced in #8597.)

comment:2 Changed 9 years ago by MarcT <myrdhn@…>

I can confirm Jim's reported issues as well, however I am using the correct version of PHP, 5.3.

comment:3 Changed 9 years ago by MarcT <myrdhn@…>

Additionally on the listings page the day/date dropdown box is not always populating. If you refresh a few times it sill finally populate. The time dropdown is always filled in.

comment:4 Changed 9 years ago by anonymous

"Frequency ID" is blank for all channels in "Channel Info". Clicking on "Source ID" will not sort channel by Source ID list in "Channel Info". Actually clicking on any header will not change the sorting order. Hard to tell, because I can't sort the list, but either all channels are marked visible even when they are not, or channels marked not visible are not being listed.

I don't dare change anything in the channel list as I suspect it would destroy my channels in its current condition.

comment:5 Changed 9 years ago by Doug Haber <doug@…>

I posted a patch for the "Length" and "Recorded Length" issues noted above at #8614 . I'm not sure if it's a correct solution but it works for me and may be a first step.

-D

comment:6 Changed 9 years ago by Doug Haber <doug@…>

I think there's a more correct solution for issues 1 and 2 in #8614 and a fix for 3 in #8616.

Thanks!
Doug

comment:7 Changed 9 years ago by MarcT <myrdhn@…>

I applied the solutions from #8614 and #8616. It fixed the issues outline in both of those tickets as well as the original issue of this case of the missing episode numbers in the dropdown.

comment:8 Changed 9 years ago by sphery

Resolution: duplicate
Status: newclosed
Version: UnspecifiedTrunk Head

dup of #8614 and #8616

Note: See TracTickets for help on using tickets.