Opened 10 years ago

Closed 10 years ago

#8603 closed patch (fixed)

EIA-608 closed captions don't start automatically

Reported by: Jim Stichnoth <stichnot@…> Owned by: markk
Priority: minor Milestone: unknown
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

With analog closed captions enabled by default (DefaultCCMode=1 and PreferCC708=0), they often become disabled immediately after the start of playback. I believe this happens on ATSC recordings when the first cc packet encountered is EIA-708 and then shortly after an EIA-608 cc packet is found. The second call to NVP::SetCaptionsEnabled? calls NVP::DisableCaptions?(kDisplayCC708) which calls osd->EnableSubtitles?(kDisplayNone).

The attached patch fixes this behavior, though I don't know if it's the best solution.

Attachments (1)

fix_auto_captions.patch (604 bytes) - added by Jim Stichnoth <stichnot@…> 10 years ago.

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by Jim Stichnoth <stichnot@…>

Attachment: fix_auto_captions.patch added

comment:1 Changed 10 years ago by markk

Owner: changed from Isaac Richards to markk
Status: newaccepted

comment:2 Changed 10 years ago by markk

Resolution: fixed
Status: acceptedclosed

(In [25702]) Improved subtitle track re-initialisation after the decoder detects new streams.

Only trigger changes if the player determines that a different track type is now preferred and disable the existing subtitle type first.

Finally, fix the DisableCaptions? function to ensure we don't inadvertently disable captions that are actually meant to be visible.

Closes #8603

Note: See TracTickets for help on using tickets.