Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 4 years ago

Closed 4 years ago

#8608 closed defect (invalid)

MythVideo cannot find coverart after scan for changes

Reported by: Keven Scharaswak <hicotton02@…> Owned by: awithers
Priority: minor Milestone: unknown
Component: Plugin - MythVideo Version: 0.23-fixes
Severity: medium Keywords: mythvideo coverart metadata
Cc: Ticket locked: yes

Description

I have a nfs mount on my frontend/backend setup (to a media server) that hosts my videos for MythVideo?, and when i get the metadata for the video, it works fine. After a "scan for changes", where the coverart normally is, it is now a grey box. Mythfrontend show an error:

2010-06-24 11:48:39.975 Unable to find image file: 3021_coverart.jpg

2010-06-24 11:48:39.976 Unable to find image file: 7840_coverart.jpg

a quick "ls -latr" in /var/lib/mythtv/coverart shows:

-rw-r--r-- 1 theskaz mythtv 628917 2010-06-23 19:14 3021_coverart.jpg

-rw-r--r-- 1 theskaz mythtv 321663 2010-06-23 20:34 7840_coverart.jpg

(This is just a snippet, the error is for every single coverart/fanart/screenshot on my system. If i reset the metadata, then redownload it, it will find it again until the next time.

MythTV Version : 24158
MythTV Branch : branches/release-0-23-fixes
Network Protocol : 56
Library API : 0.23.20100314-1
QT Version : 4.6.2
Options compiled in:

linux debug using_oss using_alsa using_pulse using_jack using_pulseoutput using_backend using_dvb using_firewire using_frontend using_glx_proc_addr_arb using_hdhomerun using_hdpvr using_iptv using_ivtv using_joystick_menu using_libudev using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_libavc_5_3 using_live using_mheg

Attachments (0)

Change History (4)

comment:1 Changed 4 years ago by robertm

  • Resolution set to invalid
  • Status changed from new to closed

You have conflicting local and storage group entries. You can use one or the other, not both.

comment:2 Changed 4 years ago by harvest316@…

  • Resolution invalid deleted
  • Status changed from closed to new

I have the same problem. Not sure what you meant about storage groups, robertm. I've looked in the storagegroup table, and there's no duplication across servers. I've 'edited' all directories in all storage groups on both backends, to trigger the test creation of the .test file, and it all works fine. Any other ideas?

comment:3 Changed 4 years ago by harvest316@…

To clarify: what works fine is the backend setup verifying all storage group directories.

I confirm /var/lib/mythtv/coverart is drwsrwsr-x

JAMU also has trouble finding the coverart, because the --mythtvjanitor will just delete the images.

The only workaround is to put the full path in the coverfile column of the videometadata table. But I'd like a less hacky solution if we can manage it.

The only pertinent entries from mythfrontend -v all:

2010-06-28 23:55:48.060 Warning: container 'mythvideo' is missing child 'coverart'
2010-06-28 23:55:48.060 Warning: container 'mythvideo' is missing child 'screenshot'
2010-06-28 23:55:48.060 Warning: container 'mythvideo' is missing child 'banner'
...
2010-06-28 23:55:48.232 Unable to find image file: 11285_coverart.jpg
2010-06-28 23:55:48.232 MythUIImage::LoadImage? Could not load :11285_coverart.jpg:

comment:4 Changed 4 years ago by wagnerrp

  • Resolution set to invalid
  • Status changed from new to closed
  • Ticket locked set

As mentioned, the issue is because you have both storage groups and local folder paths defined to the same directory. This is causing problems with MythVideo?'s use of hashing, and the scanner moving the entry between local and remote paths. That is a misconfiguration. Please remove the path you have set in the frontend configuration for MythVideo?.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.