Opened 9 years ago

Closed 9 years ago

#8611 closed patch (fixed)

Resuming playback from last played track / position is not working properly when mythmusic "Exit action" is set to "Keep playing"

Reported by: Martin Louda <sandin@…> Owned by: paulh
Priority: minor Milestone: 0.24
Component: Plugin - MythMusic Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I wonder why this was left so long undiscovered, but there is a bug that causes track or position is not remembered when leaving mythmusic player screen - when "Resume mode" is set to "Track" or "Exact". If "Exit action" is set to "Keep playing" current track or position is never remembered. I assume this is not an intended behavior since "Resume mode" setting should be respected and is not related to "Exit action".

The faulty behavior can be reproduced by following steps:

  • set "Resume mode" to "Track" or "Exact"
  • set "Exit action" to "Keep playing"
  • enter main player screen, play second track in playlist (active queue)
  • hit stop or pause, exit main player screen
  • enter main player screen and first track in playlist will play (this is wrong, second track should be played)

Proposed patch is attached.

Attachments (1)

save_position.patch (794 bytes) - added by Martin Louda <sandin@…> 9 years ago.

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by Martin Louda <sandin@…>

Attachment: save_position.patch added

comment:1 Changed 9 years ago by robertm

Milestone: unknown
Owner: changed from Isaac Richards to paulh
Status: newassigned

comment:2 Changed 9 years ago by paulh

Milestone: unknown0.24

comment:3 Changed 9 years ago by paulh

Resolution: fixed
Status: assignedclosed

(In [25681]) MythMusic: Make sure we save the current position when exiting the playback screen and the player is stopped. Patch from Martin Louda. Fixes #8611.

Note: See TracTickets for help on using tickets.