Opened 9 years ago

Closed 9 years ago

#8619 closed Developer Task (Fixed)

mythtvosd doesn't update the OSD

Reported by: Doug Haber <doug@…> Owned by: markk
Priority: minor Milestone: 0.25
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description

I think this may be since the new OSD merge but I didn't notice it until today. I'm trying lines like:

mythtvosd --template=cid --verbose --caller_name="doug"
Thanks!
Doug

Attachments (1)

mf.log (699 bytes) - added by Doug Haber <doug@…> 9 years ago.

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by Doug Haber <doug@…>

Attachment: mf.log added

comment:1 Changed 9 years ago by Doug Haber <doug@…>

After doing a little research I found that the following code is commented out about line 11931 in tv_play.cpp:


/*
    if (osd && set)
        osd->StartNotify(set);
    else if (osd && !name.isEmpty())
        osd->ClearNotify(name);
*/


This seems to explain why the Notify doesn't show up on the OSD. StartNotify? & ClearNotify? are not implemented in osd.cpp any more (presumably because the OSD code was totally re-written).


Hope this helps!

Doug

comment:2 Changed 9 years ago by robertm

Owner: changed from Isaac Richards to markk
Status: newassigned

comment:3 Changed 9 years ago by markk

Milestone: unknown0.25
Status: assignedaccepted

comment:4 Changed 9 years ago by stuartm

Milestone: 0.25

Milestone 0.25 deleted

comment:5 Changed 9 years ago by anonymous

Same problem when updating from 0.23 to 0.24. I no longer get any kind of reaction from from mythtvosd commands that previously has been working for several years. This is kind of annoying, and I hope it'll be fixed in 0.24 still.

comment:6 Changed 9 years ago by sphery

Ticket locked: set

comment:7 Changed 9 years ago by stuartm

Type: defectDeveloper Task

Not a bug.

comment:8 Changed 9 years ago by markk

see SHA: f6de5dde76146b980203 and SHA: e7668a997cda3e5419e3 for initial checkin of replacement functionality.

comment:9 Changed 9 years ago by markk

Resolution: Fixed
Status: acceptedclosed

mythtvosd was replaced with mythmessage in bd469cf06576877789b1

Note: See TracTickets for help on using tickets.