Opened 9 years ago

Closed 9 years ago

#8623 closed defect (fixed)

MythWeather not updating weather maps properly

Reported by: beirdo Owned by: beirdo
Priority: minor Milestone: unknown
Component: Plugin - MythWeather Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I left mythweather running overnight, and the static maps did not ever update. As far as I can tell, the image has been updated in the cache directory, but mythweather never bothers to update.

My suspicion is that as the cache file contents don't change, the code doesn't bother to check if the image has changed. If this is the case, the code needs to actually check the mtime of the file. Either way, this needs fixing.

Change History (2)

comment:1 Changed 9 years ago by beirdo

Status: newaccepted

comment:2 Changed 9 years ago by beirdo

Resolution: fixed
Status: acceptedclosed

(In [25220]) The weather maps will now update to the screen when an update happens. Also, I tweaked the internal update check time to give a padding of 15s as the update time stored to the database is post-update, and the update scripts can take some time. Without this padding, the first update can easily be missed, and the padding allows for 15s of execution time. This may need more tweaking.

Finally, before processing data from a script, the DataMap? is now cleared to prevent accumulation of text caused by the code that allows for multi-line output from the scripts.

Closes #8623

Note: See TracTickets for help on using tickets.