Opened 10 years ago

Closed 10 years ago

#8635 closed defect (duplicate)

image downloads from themoviedb.org nolonger working on frontend

Reported by: MarcT <myrdhn@…> Owned by: Anduin Withers
Priority: minor Milestone: unknown
Component: Plugin - MythVideo Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I recently setup storage groups for mythvideo and split my ISOs into a separate folder on a frontend machine. DOWNLOADDATA command (W key) fails due to themoviedb.com using redirects. Metadata still comes across fine, the images do not.

2010-07-02 00:12:21.201 Metadata Image Download: http://hwcdn.themoviedb.org/posters/a32/4bc95853017a3c57fe027a32/avatar-original.jpg ->/media/ISOs/metadata/Covers/19995_coverart.jpg
2010-07-02 00:12:21.260 Tried to write http://hwcdn.themoviedb.org/posters/a32/4bc95853017a3c57fe027a32/avatar-original.jpg, but it appears to be an HTML redirect (filesize 210).
2010-07-02 00:12:21.261 Metadata Image Download: http://hwcdn.themoviedb.org/backdrops/a0e/4bc95848017a3c57fe027a0e/avatar-original.jpg ->/media/ISOs/metadata/Fanart/19995_fanart.jpg
2010-07-02 00:12:21.319 Tried to write http://hwcdn.themoviedb.org/backdrops/a0e/4bc95848017a3c57fe027a0e/avatar-original.jpg, but it appears to be an HTML redirect (filesize 212).

If I goto http://hwcdn.themoviedb.org/posters/a32/4bc95853017a3c57fe027a32/avatar-original.jpg I get redirected to http://69.16.184.117/x9z7i7v3/cds/posters/a32/4bc95853017a3c57fe027a32/avatar-original.jpg?dopvhost=hwcdn.themoviedb.org&doppl=450e5b0009233057097330074c63882a9da681a3&dopsig=6936cc0ab52f1baeea6ec0f69bb13cb2 so the error seems to be correct. But we still need a way to download the images. Jamu works correctly on downloading from themoviedb.org. But that is on my backend and I'm trying to download the images for the ISOs that are on my frontend.

mythfrontend --version
Please attach all output as a file in bug reports.
MythTV Version   : 25243M
MythTV Branch    : trunk
Network Protocol : 57
Library API      : 0.23.20100630-3
QT Version       : 4.6.2
Options compiled in:
 linux debug using_oss using_alsa using_backend using_frontend using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_opengl using_vdpau using_ffmpeg_threads using_mheg

Change History (2)

comment:1 Changed 10 years ago by MarcT <myrdhn@…>

Close this as a duplicate of #8634

comment:2 Changed 10 years ago by sphery

Resolution: duplicate
Status: newclosed

dup of #8634

Note: See TracTickets for help on using tickets.