Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8650 closed defect (fixed)

Problems with MythWelcome screen, Version MythTV .24

Reported by: garduman@… Owned by: paulh
Priority: minor Milestone: 0.24
Component: MythTV - General Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

  1. When exiting MythTV to return to the Mythwelcome screen, using the remote, it is necessary to use the right arrow key after selecting Yes, Exit now. May be necessary to complete this procedure twice for it to work. Using the OK button causes it to loop back to the main menu.
  1. Mythwelcome screen randomly displays that it is locked. Usually requires going out of the screen and returning for the unlock to work.
  1. Randomly, processes such as selecting a new TV channel can return you to the Mythwelcome screen.
  1. Mythwelcome log is blank.

Attachments (3)

mythfrontend.log (439.2 KB) - added by garduman@… 9 years ago.
mythbackend.txt (197.4 KB) - added by anonymous 9 years ago.
mythwelcome_log.txt (45.3 KB) - added by Noah K <bodhileok@…> 9 years ago.
combined mythwelcome/mythfrontend log for multiple shutdown lock problem

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by garduman@…

Attachment: mythfrontend.log added

Changed 9 years ago by anonymous

Attachment: mythbackend.txt added

comment:1 Changed 9 years ago by Matthew Wire <devel@…>

Note that issue 3 is a mythfrontend crash and has nothing to do with mythwelcome (I see this issue too but have not had time to identify the issue and report it yet).

comment:2 Changed 9 years ago by robertm

Owner: changed from Isaac Richards to paulh
Status: newassigned

comment:3 Changed 9 years ago by bodhileok@…

I am seeing (1) and (2) above, though restarting mythwelcome does not solve (2) for me, as it seems to for garduman. Also, I don't use "prompt on exit", so for me (1) just means mythfrontend restarts when I exit it. A couple of extra data points:

I've been able to determine that (1) (which happens very frequently for me, whenever I've been using mythfrontend for a while, though I haven't found an exact formula to reproduce it) is associated with a call to WelcomeDialog::startFrontendClick(), even though I haven't clicked anything.

(2) happens about once a week for me. Attached is a combined mythwelcome/mythfrontend log from one of these times. There are many consecutive "Launching: /usr/local/bin/mythshutdown --lock" statements. Since mythshutdown increments MythShutdownLock? by 1 for each of these, this results in a large value of MythShutdownLock?, so equally as many "unlock shutdown" actions (which decrement by 1) via the popup menu would be required to unlock, giving the appearance that unlocking is broken. Unclear to me what is causing these multiple consecutive locks.

I am using Kubuntu 10.04 32-bit.

Changed 9 years ago by Noah K <bodhileok@…>

Attachment: mythwelcome_log.txt added

combined mythwelcome/mythfrontend log for multiple shutdown lock problem

comment:4 Changed 9 years ago by Noah K <bodhileok@…>

Sorry for extra noise-- that log I attached also shows my debugging code showing startFrontendClick being called, resulting in mythfrontend restarting (ie both problems (1) and (2) occurred), even though I hadn't clicked anything.

comment:5 Changed 9 years ago by paulh

Resolution: fixed
Status: assignedclosed

1 and possibly 2 was caused by myth_system() not disabling lirc while the FE was running which has recently been fixed by beirdo.

3 has nothing to do with MythWelcome? it is the FE crashing which takes you back to MythWelcome?.

4 works for me and others judging by the logs attached to this ticket.

comment:6 Changed 9 years ago by paulh

Milestone: unknown0.24
Note: See TracTickets for help on using tickets.