Opened 9 years ago

Closed 9 years ago

#8653 closed defect (duplicate)

MythTV does not record rerun of failed recording

Reported by: thomas@… Owned by: gigem
Priority: minor Milestone: unknown
Component: MythTV - Scheduling Version: 0.23-fixes
Severity: medium Keywords:
Cc: thomas@… Ticket locked: no

Description

I am using DVB-S and I will lose sometimes the signal when there is a thunderstorm. MythTV recognizes this and flags the recording as "f" (can be seen in the old recordings screen). But it does not automatically record the rerun. MythWeb says for the rerun in the upcoming list: "recorded earlier".

I have seen this in 0.22 and 0.23.

From the log (unfortunately not with -v schedule):

2010-07-14 19:56:46.543 DevRdB(/dev/dvb/adapter0/frontend0) Error: Poll giving up

2010-07-14 19:56:46.548 DVBSH(/dev/dvb/adapter0/frontend0) Error: Device error detected

2010-07-14 19:56:47.070 DVBRec(2:/dev/dvb/adapter0/frontend0) Error: Stream handler died unexpectedly.

2010-07-14 19:56:47.466 TVRec(2): Changing from RecordingOnly? to None

2010-07-14 19:56:47.468 ProgramInfo?(): Updated pathname : -> '13003_20100714193500.mpg'

2010-07-14 19:56:47.472 ProgramInfo?(13003_20100714193500.mpg), Error: Unknown type, recording width was 720

2010-07-14 19:56:47.479 ProgramInfo?(): Updated pathname : -> '13003_20100714193500.mpg'

2010-07-14 19:56:47.492 Reschedule requested for id 0.

2010-07-14 19:56:47.523 ProgramInfo?(): Updated pathname : -> '13003_20100714193500.mpg'

Attachments (1)

mythbackend.log (336.2 KB) - added by thomas@… 9 years ago.
Backend log of the situation

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by sphery

dup of #3872

comment:2 Changed 9 years ago by thomas@…

Correct, it's a dup. I do not have 0 byte recordings however when the thunderstorm starts in the middle of the recording. So, 0 bytes should not be the indicator that it should record the rerun.

comment:3 Changed 9 years ago by thomas@…

I am going to attach a log with -v schedule about the situation.

Started mythbackend at 2010-07-16, 19:30. Test recording "Gute Zeiten, schlechte Zeiten", description "Serie, Deutschland, 2010, Folge 452" begins at 19:40, record early 5 min -> 19:35.

The show is scheduled as "Record at any time on any channel.", Duplicate Check "Description".

Recording starts at 19:35.

Disconnected SAT cable at 19:40. After a while, recording fails. Status of recording is "f".

The rerun is at 2010-07-19, 08:30 (minus 5 min -> 8:25). This time slot has status "R". It will not be recorded.

Changed 9 years ago by thomas@…

Attachment: mythbackend.log added

Backend log of the situation

comment:4 Changed 9 years ago by gigem

Resolution: duplicate
Status: newclosed

As sphery noted, this is a duplicate of #3872

Note: See TracTickets for help on using tickets.