Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 4 years ago

Closed 13 months ago

Last modified 13 months ago

#8657 closed Bug Report - General (fixed)

Mytharchive import fails if no storage groups are defined locally

Reported by: jtlarson@… Owned by: paulh
Priority: trivial Milestone: 0.26.1
Component: Plugin - MythArchive Version: 0.23-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

I have 4 slave servers--each with local storage (all cross-mounted via NFS), but the storage directories are defined on the master backend default SG, since they are shared among all the servers.

When running the mytharchive import process on one of the slave boxes, it errors out like this:
2010-07-15 09:52:48.473 copying from /myth/windows/avpc2/tmp/Test recording/1000_20100707111400.mpg
2010-07-15 09:52:48.473 to /1000_20100707111400.mpg
2010-07-15 09:52:48.474 ERROR: Unable to open destination file
2010-07-15 09:52:48.474 Do you have write access to the directory?

Notice that the destination path is "/1000_20100707111400.mpg"--it should be "/mnt/sbe3/rec11000_20100707111400.mpg". I believe that mytharchive is simply looking for folders in the 'Default' SG that match the local hostanme--and if none are found the query returns nothing and the script chokes. See the following link for a little more detail: http://ubuntuforums.org/showpost.php?p=4844808&postcount=6

Attachments (0)

Change History (8)

comment:1 Changed 4 years ago by robertm

  • Priority changed from major to trivial
  • Severity changed from medium to low

Please see the ticket howto, do not set priority/severity.

comment:2 Changed 4 years ago by robertm

  • Status changed from new to assigned

comment:3 Changed 2 years ago by stuartm

  • Type changed from defect to Bug Report - General

Any chance that this has been fixed already? It's against 0.23

comment:4 Changed 2 years ago by paulh

  • Owner paulh deleted

comment:5 Changed 16 months ago by paulh <mythtv@…>

This was fixed in my fork in ​https://github.com/paul-h/mythtv/commit/fcfe61b1bb

Note there seems to be a regression introduced by the socket changes that causes file transfers to abort early. I had to increase the timeout to 100ms in FileTransfer::WriteBlock?() to get the file transfer to work reliably.

comment:6 Changed 13 months ago by Paul Harrison <mythtv@…>

  • Owner set to Paul Harrison <mythtv@…>
  • Resolution set to fixed
  • Status changed from assigned to closed

In 003f3023f2483f88f84df73b41fe2f976bb119d0/mythtv:

MythArchive?: fix the import/export of recordings to the native archive format

  • This updates the native import/export to work with the current DB table fields. Fixes #10871
  • Add storage group support so the FE running MythArchive? no longer needs local access to the recordings. Fixes #8657.

comment:7 Changed 13 months ago by Paul Harrison <mythtv@…>

In 854cb0c3b663d6aa37d9ea4484964bd1c899ec81/mythtv:

MythArchive?: fix the import/export of recordings to the native archive format

  • This updates the native import/export to work with the current DB table fields. Fixes #10871
  • Add storage group support so the FE running MythArchive? no longer needs local access to the recordings. Fixes #8657.

(cherry picked from commit 003f3023f2483f88f84df73b41fe2f976bb119d0)

comment:8 Changed 13 months ago by paulh

  • Milestone changed from unknown to 0.26.1
  • Owner changed from Paul Harrison <mythtv@…> to paulh

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.