Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8683 closed defect (duplicate)

"From CD" causes Segmentation Fault

Reported by: Matthew Wire <devel@…> Owned by: Isaac Richards
Priority: minor Milestone: unknown
Component: Plugin - MythMusic Version: Master Head
Severity: medium Keywords: crash cd segfault
Cc: Ticket locked: no

Description

In mythmusic, opening the menu and selecting "From CD" causes a Segmentation Fault.

Extract from frontend log with additional debug info compiled in to show it gets past the end of closePlaylistPopup: 2010-07-22 21:48:05.957 XMLParse: LoadTheme? using '/usr/share/mythtv/themes/default/music-ui.xml' 2010-07-22 21:48:08.170 closePlaylistPopup after hide() 2010-07-22 21:48:08.171 closePlaylistPopup after deleteLater() 2010-07-22 21:48:08.171 closePlaylistPopup after NULL 2010-07-22 21:48:08.386 CD status has changed. 2010-07-22 21:48:22.263 AO: Resampling from 44 kHz to 48 kHz with quality medium 2010-07-22 21:48:22.263 AO: Opening audio device 'PulseAudio:default' ch 2(2) sr 48000 sf 32 bit floating point reenc 0 Segmentation fault

I have two systems setup. Both ubuntu lucid 64bit. This occurs with latest trunk

Attachments (1)

mythtv_backtrace.txt (18.9 KB) - added by Matthew Wire <devel@…> 9 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 9 years ago by robertm

Status: newinfoneeded_new

We will need a backtrace per the manual.

http://www.mythtv.org/wiki/Debugging

Changed 9 years ago by Matthew Wire <devel@…>

Attachment: mythtv_backtrace.txt added

comment:2 Changed 9 years ago by Matthew Wire <devel@…>

Apologies. Hopefully the attached backtrace is sufficient. If you require more information please let me know.

comment:3 Changed 9 years ago by paulh

Resolution: duplicate
Status: infoneeded_newclosed

This is a duplicate of #8506.

comment:4 Changed 9 years ago by paulh

(In [25560]) MythMusic: Make sure the decoder is stopped when updating the playlist and fix a leak in MusicNode?. Fixes #8506, #8567. Refs #8683.

Note: See TracTickets for help on using tickets.