Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8709 closed defect (duplicate)

PVR250 recordings playback with no picture

Reported by: anonymous Owned by:
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

My old PVR250 recordings do not have a picture but do have sound when played back with the latest trunk (I haven't attempted to play one in a few months, so do not have any good bracketing info). My hdhr, firewire and hdpvr recordings all play fine.

Using Trunk r25498 with vdpau. Switching to ffmpeg makes no difference.

mythfrontend -v playback,important:

2010-07-30 01:53:39.641 Searching for frame header. 2010-07-30 01:53:39.687 Searching for frame header. 2010-07-30 01:53:39.691 Searching for frame header. 2010-07-30 01:53:39.716 Broken packet: X 1157627904 2010-07-30 01:53:39.732 Searching for frame header. 2010-07-30 01:53:39.778 Searching for frame header. 2010-07-30 01:53:39.786 Searching for frame header. 2010-07-30 01:53:39.794 Broken packet: Q 931659776 2010-07-30 01:53:39.824 Broken packet: T 565837824 2010-07-30 01:53:39.944 SendReceiveStringList?(MESSAGE,SYSTEM_EVENT PLAY_STOPPED HOSTNAME mythbox CHANID 2013 STARTTIME 2003-11-19T19:30:00 SENDER mythbox) called from UI thread

Change History (5)

comment:1 Changed 9 years ago by robertm

Status: newinfoneeded_new

Do the recordings themselves have video? What happens when played elsewhere? This smells like a driver issue.

comment:2 Changed 9 years ago by anonymous

The recordings all have video and all previously played in previous versions (still cannot say definitively when I last viewed them). They also currently play fine in VLC. They are for the most part all 5+ years old and were recorded when all recordings were named as ".nuv".

On further inspection, I had transcoded them all using Myth's transcoder. From midentify:

ID_VIDEO_ID=0
ID_AUDIO_ID=1
ID_FILENAME=1061_20050227150200_20050227160000.nuv
ID_DEMUXER=lavfpref
ID_VIDEO_FORMAT=DIVX
ID_VIDEO_BITRATE=0
ID_VIDEO_WIDTH=720
ID_VIDEO_HEIGHT=480
ID_VIDEO_FPS=29.917
ID_VIDEO_ASPECT=1.3333
ID_AUDIO_FORMAT=LAME
ID_AUDIO_BITRATE=128000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
ID_LENGTH=71783.37
ID_SEEKABLE=1
ID_CHAPTERS=0
ID_VIDEO_CODEC=ffodivx
ID_AUDIO_BITRATE=128000
ID_AUDIO_RATE=48000
ID_AUDIO_NCH=2
ID_AUDIO_CODEC=mp3
ID_EXIT=EOF

comment:3 Changed 9 years ago by anonymous

I noticed someone just opened ticket #8711 - No video for nuppelvideo recordings. Not sure if mythtranscode used to create nuppelvideo (my affected files are all named as .nuv) or not, but it's the same symptom.

comment:4 Changed 9 years ago by robertm

Resolution: duplicate
Status: infoneeded_newclosed

Dupe of #8711 (has patch)

comment:5 Changed 9 years ago by anonymous

I just want to confirm this was resolved for me by the fix of #8711. Thanks!

Note: See TracTickets for help on using tickets.