Opened 10 years ago

Closed 10 years ago

#8716 closed defect (wontfix)

Exiting mythfrontend early leaves the process running

Reported by: malcolm.parsons@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.23-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

My wife accidentally started mythfrontend from mythwelcome this morning, then immediately pressed escape to exit mythfrontend.

The mythfrontend window closed, but mythwelcome did not repaint.

ps showed that mythfrontend was still running.

I'm attaching a backtrace of the running threads.

After killing the mythfrontend process, mythwelcome repainted its window.

I was able to reproduce this several times by pressing escape before the root mythtv menu appeared.

Mythfrontend exited normally if escape was pressed after the menu appeared.

Attachments (1)

mythfrontend.gdb (25.8 KB) - added by Malcolm Parsons <malcolm.parsons@…> 10 years ago.
thread backtraces

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by Malcolm Parsons <malcolm.parsons@…>

Attachment: mythfrontend.gdb added

thread backtraces

comment:1 Changed 10 years ago by robertm

Owner: set to danielk
Status: newassigned

comment:2 Changed 10 years ago by danielk

Resolution: wontfix
Status: assignedclosed

Malcolm, thanks for the report.

I don't see anything obvious in the backtraces, since this isn't something likely to occur often I'm closing the ticket as wont fix, but if you figure this out and provide a patch I'll be happy to review it.

Note: See TracTickets for help on using tickets.