Opened 9 years ago

Closed 9 years ago

#8739 closed defect (duplicate)

Segfault during DVB-S scanning

Reported by: Nick Morrott <knowledgejunkie (at) gmail (dot) com> Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Channel Scanner Version: Master Head
Severity: medium Keywords: channel scanner dvb-s segfault
Cc: Ticket locked: no

Description

Using the same configuration as reported in #8726.

Testing DVB-S scanning has highlighted a repeatable segfault when decryption testing is enabled. Repeated testing with decryption testing disabled does not seem to provoke this segfault. This card is not using a CAM.

Testing was carried out using tuned scans (10714000/22000000) using the Astra2 cluster for UK Freesat/FTA channels.

The last output seen in the scan window was "Unknown decryption status".

Backtrace attached.

Attachments (1)

8739-gdb-dvbs-scan-segfault-r25561.txt (23.9 KB) - added by Nick Morrott <knowledgejunkie (at) gmail (dot) com> 9 years ago.
GDB backtrace for DVB-S scanning segfault

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

GDB backtrace for DVB-S scanning segfault

comment:1 Changed 9 years ago by robertm

Almost definitely a dupe of #8737.

comment:2 Changed 9 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

I was wondering that myself, but don't know enough about the various flavours of DVB scanning to be sure.

I'm testing the patch posted earlier on #8737 to see if this fixes the issue. Apologies I didn't notice the patch before opening the ticket.

comment:3 Changed 9 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

It seems it might be the same/similar as the DVB-C scanning bug reported on #7340 last year. I didn't see any segfault earlier when testing DVB-T scanning.

comment:4 Changed 9 years ago by Nick Morrott <knowledgejunkie (at) gmail (dot) com>

I've now tested the patch attached to #8737 and have seen no segfaults after 2 lengthy tuned scans (same settings as above) with decryption testing enabled.

comment:5 Changed 9 years ago by robertm

Resolution: duplicate
Status: newclosed

Dupe of #8737, thank you for the patch test.

Note: See TracTickets for help on using tickets.