Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8750 closed defect (fixed)

Passwords On Recording Groups Do Not Work - No Prompt Is Displayed

Reported by: anonymous Owned by: stuartm
Priority: minor Milestone: 0.24
Component: MythTV - General Version: 0.23-fixes
Severity: medium Keywords: recording groups passwords
Cc: Ticket locked: no

Description

  1. Create three recording groups. Set Default Group Filter To Apply To Default (Setup-TV Settings-Playback-Page5)
  2. On the default recording group set a password and on another recording group set the same password.
  3. Exit to main menu. Select Watching Recordings and Escape the password prompt. No recordings will be displayed - as expected.
  4. Use the M key to Change Filter and select the recording group that does not have a password - recordings are displayed - correct.
  5. Use M again and choose the Default group and the recordings are displayed - no password prompt is displayed but the recordings are still displayed - recordings that should be protected by a password!

If you keep pressing the M key choosing different recording groups the password prompt is not displayed in the majority of cases.

Doing a search of trac and the groups also come up with this problem - not exactly the same as mine (but could be same problem) but definitely related by the looks of things. So I will add this to the ticket also - please do not forget my problem above though :)

http://www.gossamer-threads.com/lists/mythtv/users/442092

Change History (3)

comment:1 Changed 9 years ago by robertm

Owner: set to stuartm
Status: newassigned

comment:2 Changed 9 years ago by stuartm

Resolution: fixed
Status: assignedclosed

(In [25746]) Cleanup recording group password handling in Watch Recordings. This probably fixes the bug in #8750 but I was unable to reproduce that. Fixes #8750, reopen if not.

comment:3 Changed 9 years ago by stuartm

Milestone: unknown0.24
Note: See TracTickets for help on using tickets.