Opened 9 years ago

Closed 9 years ago

#8764 closed defect (fixed)

lost livetv between 25601 and 25614

Reported by: yianniv Owned by: markk
Priority: minor Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I cannot watch livetv. The OSD keeps "blinking" slightly, and a black screen is for background. The system is almost responsive, I can esc back to the Tv menu. The hd is very active.

I can watch recordings and can also record using mythweb. Reverting one pc to 25601 allows me to watch tv using a card that is on another backend that is still on 25614. So, I assume it's a frontend issue.(?)

The version info from the affected pc: MythTV Version : 25614M MythTV Branch : trunk Network Protocol : 58 Library API : 0.23.20100807-1 QT Version : 4.6.3 Options compiled in:

linux release using_alsa using_oss using_pulse using_pulseoutput using_backend using_dvb using_frontend using_hdpvr using_iptv using_ivtv using_libfftw3 using_lirc using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_vdpau using_ffmpeg_threads using_live using_mheg

Change History (4)

comment:1 Changed 9 years ago by markk

Milestone: unknown0.24
Owner: set to markk
Status: newaccepted

I've spotted this today and as it's likely one of my commits was the cause, I'll try and fix it!

comment:2 Changed 9 years ago by yianniv

Thanks, It happens with 25611, too. I am attaching the relevant log:

2010-08-11 18:12:38.750 TV: Attempting to change from None to WatchingLiveTV
2010-08-11 18:12:38.750 MythCoreContext: Connecting to backend server: 192.168.13.65:6543 (try 1 of 1)
2010-08-11 18:12:38.751 Using protocol version 58
2010-08-11 18:12:38.823 Spawning LiveTV Recorder -- begin
2010-08-11 18:12:39.056 Spawning LiveTV Recorder -- end
2010-08-11 18:12:39.155 SendReceiveStringList(QUERY_CHECKFILE,0...) called from UI thread
2010-08-11 18:12:39.159 We have a playbackURL(myth://192.168.13.65:6543/1026_20100811181239.nuv) & cardtype(DUMMY)
2010-08-11 18:12:39.159 We have a RingBuffer
2010-08-11 18:12:39.208 AudioPlayer: Disabling Audio, params(0,2,44100)
2010-08-11 18:12:39.265 AO: Resampling from 44 kHz to 48 kHz with quality medium
2010-08-11 18:12:39.265 AO: Opening audio device 'default:CARD=Intel' ch 2(2) sr 48000 sf signed 32 bit reenc 0
2010-08-11 18:12:39.270 ALSA, Error: snd_pcm_info_get_card: ΠλειÏοÏÏγία δεν εÏιÏÏέÏεÏαι
2010-08-11 18:12:39.270 Opening ALSA audio device 'default:CARD=Intel'.
2010-08-11 18:12:39.276 AudioPlayer: Enabling Audio
2010-08-11 18:12:39.452 VDPAU: Created 2 output surfaces.
2010-08-11 18:12:39.452 VDPAU: Version 1
2010-08-11 18:12:39.452 VDPAU: Information NVIDIA VDPAU Driver Shared Library  256.35  Wed Jun 16 19:14:02 PDT 2010
2010-08-11 18:12:39.452 VDPAU: Created VDPAU render device 1680x1050
2010-08-11 18:12:39.550 Unable to find font: FreeSans.ttf
2010-08-11 18:12:39.554 Player(0): Video timing method: USleep with busy wait
2010-08-11 18:12:39.555 TV: Changing from None to WatchingLiveTV
2010-08-11 18:12:39.555 TV: State is LiveTV & mctx == ctx
2010-08-11 18:12:39.557 TV: UpdateOSDInput done
2010-08-11 18:12:39.557 TV: UpdateLCD done
2010-08-11 18:12:39.558 TV: ITVRestart done
2010-08-11 18:12:39.713 VDPAU: Added 2 output surfaces (total 4, max 4)
2010-08-11 18:12:39.776 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:39.942 Player(0): DecoderGetFrame() called with NULL decoder.
2010-08-11 18:12:39.970 VDPAU Painter: Clearing VDPAU painter cache.
2010-08-11 18:12:40.087 VDPAU: Created 2 output surfaces.
2010-08-11 18:12:40.087 VDPAU: Created VDPAU render device 1680x1050
2010-08-11 18:12:40.147 AO: Resampling from 32 kHz to 48 kHz with quality medium
2010-08-11 18:12:40.147 AO: Opening audio device 'default:CARD=Intel' ch 2(2) sr 48000 sf signed 32 bit reenc 0
2010-08-11 18:12:40.149 ALSA, Error: snd_pcm_info_get_card: ΠλειÏοÏÏγία δεν εÏιÏÏέÏεÏαι
2010-08-11 18:12:40.149 Opening ALSA audio device 'default:CARD=Intel'.
2010-08-11 18:12:40.361 VDPAU: Added 2 output surfaces (total 4, max 4)
2010-08-11 18:12:40.382 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:40.686 Player(0): DecoderGetFrame() called with NULL decoder.
2010-08-11 18:12:40.859 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:41.023 Player(0): DecoderGetFrame() called with NULL decoder.
2010-08-11 18:12:41.220 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:41.391 Player(0): DecoderGetFrame() called with NULL decoder.
2010-08-11 18:12:41.548 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:41.715 Player(0): DecoderGetFrame() called with NULL decoder.
2010-08-11 18:12:41.916 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:42.077 Player(0): DecoderGetFrame() called with NULL decoder.
2010-08-11 18:12:42.249 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:42.396 Player(0): DecoderGetFrame() called with NULL decoder.
2010-08-11 18:12:42.565 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:42.715 Player(0): DecoderGetFrame() called with NULL decoder.
2010-08-11 18:12:42.798 Player(0): Waited 100ms for video buffers AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
2010-08-11 18:12:42.918 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:43.123 Player(0): DecoderGetFrame() called with NULL decoder.
2010-08-11 18:12:43.321 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:43.482 Player(0): DecoderGetFrame() called with NULL decoder.
2010-08-11 18:12:43.656 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:43.835 Player(0): DecoderGetFrame() called with NULL decoder.
2010-08-11 18:12:44.054 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:44.210 Player(0): DecoderGetFrame() called with NULL decoder.
2010-08-11 18:12:44.400 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:44.557 Player(0): DecoderGetFrame() called with NULL decoder.
2010-08-11 18:12:44.752 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:44.923 Player(0): DecoderGetFrame() called with NULL decoder.
2010-08-11 18:12:45.131 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_CHANGED HOSTNAME storage CHANID 1026 STARTTIME 2010-08-11T18:12:40 SENDER storage) called from UI thread
2010-08-11 18:12:52.146 MythSocket(7fce642de550:72): readStringList: Error, timed out after 7000 ms.
2010-08-11 18:12:52.146 RemoteFile::openSocket(control socket), Error: 
                        Could not read string list from server 192.168.13.65:6543
2010-08-11 18:12:59.150 MythSocket(7fce6524d400:72): readStringList: Error, timed out after 7000 ms.
2010-08-11 18:12:59.150 RemoteFile::openSocket(file data socket), Error: Did not get proper response from 192.168.13.65:6543
2010-08-11 18:12:59.150 RemoteFile::openSocket(file data socket), Error: Failed to open socket, error was invalid response
2010-08-11 18:12:59.150 RingBuffer::RingBuffer(): Failed to open remote file (myth://192.168.13.65:6543/1026_20100811181240.nuv)
2010-08-11 18:12:59.150 Player(0), Error: JumpToProgram's OpenFile failed.
2010-08-11 18:12:59.150 Player(0), Error: Unknown recorder error, exiting decoder
2010-08-11 18:12:59.173 TV: Attempting to change from WatchingLiveTV to None
2010-08-11 18:12:59.174 VDPAU Painter: Clearing VDPAU painter cache.
2010-08-11 18:12:59.220 ALSA, Error: snd_pcm_info_get_card: ΠλειÏοÏÏγία δεν εÏιÏÏέÏεÏαι
2010-08-11 18:13:06.227 MythSocket(7fce70141480:43): readStringList: Error, timed out after 7000 ms.
2010-08-11 18:13:06.227 RemoteEncoder::SendReceiveStringList(): No response.
2010-08-11 18:13:06.227 TV: Changing from WatchingLiveTV to None
2010-08-11 18:13:06.227 MythCoreContext: Connecting to backend server: 192.168.13.65:6543 (try 1 of 1)
2010-08-11 18:13:13.227 MythSocket(9f8630:24): readStringList: Error, timed out after 7000 ms.
2010-08-11 18:13:13.227 Protocol version check failure.
                        The response to MYTH_PROTO_VERSION was empty.
                        This happens when the backend is too busy to respond,
                        or has deadlocked in due to bugs or hardware failure.
2010-08-11 18:13:13.227 RemoteEncoder::Setup(): Failed to connect to backend
2010-08-11 18:13:13.227 RemoteEncoder::SendReceiveStringList(): Failed to reconnect with backend.
2010-08-11 18:13:13.249 TV: Attempting to change from None to None
2010-08-11 18:13:13.249 MythCoreContext: Connecting to backend server: 192.168.13.65:6543 (try 1 of 1)
2010-08-11 18:13:14.037 Using protocol version 58
2010-08-11 18:13:14.926 TV: Attempting to change from None to None
2010-08-11 18:13:14.953 TV: Attempting to change from None to None
2010-08-11 18:13:14.954 SendReceiveStringList(GET_FREE_RECORDER_COUNT) called from UI thread
2010-08-11 18:13:14.999 SendReceiveStringList(GET_NEXT_FREE_RECORDER,-1) called from UI thread
2010-08-11 18:13:15.034 TV: Attempting to change from None to WatchingLiveTV
2010-08-11 18:13:15.034 MythCoreContext: Connecting to backend server: 192.168.13.100:6543 (try 1 of 1)
2010-08-11 18:13:15.035 Using protocol version 58
2010-08-11 18:13:15.070 Spawning LiveTV Recorder -- begin
2010-08-11 18:13:18.768 Spawning LiveTV Recorder -- end
2010-08-11 18:13:18.784 We have a playbackURL(/store/readonly/myth/tvlive/1033_20100811181316.nuv) & cardtype(DUMMY)
2010-08-11 18:13:18.788 We have a RingBuffer
2010-08-11 18:13:18.788 playCtx, Error: Attempting to setup a player, but it already exists.
2010-08-11 18:13:18.788 TV Error: LiveTV not successfully started
2010-08-11 18:13:20.035 SendReceiveStringList(MESSAGE,SYSTEM_EVENT PLAY_STOPPED SENDER storage) called from UI thread

comment:3 Changed 9 years ago by yianniv

#25604 is the culprit!

comment:4 Changed 9 years ago by markk

Resolution: fixed
Status: acceptedclosed

(In [25620]) Fix a typo in r25604. Closes #8764.

Note: See TracTickets for help on using tickets.