Opened 9 years ago

Closed 8 years ago

#8794 closed Bug Report - General (Works for me)

Can't use "enter" when searching in MythWeb

Reported by: skd5aner <skd5aner@…> Owned by: Rob Smith
Priority: minor Milestone: 0.24.1
Component: Plugin - MythWeb Version: 0.23-fixes
Severity: medium Keywords: search
Cc: Ticket locked: no

Description

When trying to use the primary search box in the header of mythweb pages, search results will only return when clicking the "search" button next to the search text field.

If a user enters data in the textbox, and simply hits the "enter" key while the cursor is still in the search textbox, then the user is redirected to the search page, with no results and nothing searched for.

This has been going on for many years and releases.

Kormoc mentioned in IRC that this may be due to a design decision many years ago designed to "eat enters to prevent folks from accidentally searching". I believe that may not be the desired intention anymore since the user experience is very confusing. It took me a long time to know that I could "work-around" this issue by using the mouse and clicking search instead of hitting enter. Before I realized that, I just thought I always had to navigate to the search page first, add a string, then click search.

Change History (3)

comment:1 Changed 9 years ago by robertm

Status: newassigned

comment:2 Changed 8 years ago by stuartm

Type: defectBug Report - General

comment:3 Changed 8 years ago by stuartm

Milestone: unknown0.24.1
Resolution: Works for me
Status: assignedclosed

Actually this one seemed simple to double-check and I cannot reproduce with 0.24-fixes

Note: See TracTickets for help on using tickets.