Modify

Opened 8 years ago

Closed 8 years ago

Last modified 7 years ago

#8795 closed defect (fixed)

mythfilldatabase on OSX errors on startup

Reported by: ramccor@… Owned by: nigel
Priority: minor Milestone: 0.24
Component: Ports - OSX Version: 0.23-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

If you just double click on the executable, OSX passes the "process serial number" in via the command line. The client will exit with an invalid command line option. Since this option is really only needed when an app is launched via launchd, the best manner to correct the issue is to just strip it from processing. This effects both 0.23-fixes and trunk.

Attachments (1)

main.cpp.diff (526 bytes) - added by ramccor@… 8 years ago.
diff to mythfilldatabase to strip the -psn command line option that OSX adds.

Download all attachments as: .zip

Change History (8)

Changed 8 years ago by ramccor@…

diff to mythfilldatabase to strip the -psn command line option that OSX adds.

comment:1 Changed 8 years ago by robertm

  • Component changed from MythTV - Mythfilldatabase to Ports - OSX
  • Owner changed from stuartm to nigel
  • Status changed from new to assigned

mythfilldatabase is not intended to be a clickable executable. It's meant to be run by the backend, or from the command line. Nigel and/or Mark, do we need this?

comment:2 Changed 8 years ago by nigel

  • Status changed from assigned to accepted

The packaging script does create a standaline clickable MythFrontend.app, so this is worth fixing.
The question is, why don't MythFrontend.app or MythTV-setup.app have the same problem? What has changed?

comment:3 Changed 8 years ago by nigel

Er, last comment should have been "does create a standalone clickable MythBackend?.app". In fact, with --enable-jobtools and --enable-backend, it builds packages for: mythbackend, mythcommflag, mythfilldatabase, mythjobqueue and mythtranscode. I thought they used to be double-clickable, but maybe I am wrong - they should probably be built with different bundling options (!LSUIElement?).
For now, an extra check in MythCommandLineParser? will fix most of these.

comment:4 Changed 8 years ago by nigel

(In [25798]) Ignore Mac OS X argument -psn_X_YYYYY from double-clicked app bundles. This fixes MythBackend?.app, MythCommFlag?.app and MythJobQueue?.app. Refs #8795

comment:5 Changed 8 years ago by nigel

  • Resolution set to fixed
  • Status changed from accepted to closed

(In [25799]) Ignore Mac OS X argument -psn_X_YYYYY. I tried fixing by adding LSBackgroundOnly in the bundle's Info.plist, but sadly something else is also needed, so do it the simpler way. Thanks for the ticket and patch, Ronald! Closes #8795. Only MythTranscode?.app to go, and since I never added drag-and-drop support to that, there isn't much keeping it built as a double-clickable bundle.

comment:6 Changed 8 years ago by nigel

(In [25800]) Take MythTranscode?.app out of app list packaged for backend builds. Refs #8795

comment:7 Changed 7 years ago by stuartm

  • Milestone changed from unknown to 0.24

Add Comment

Modify Ticket

Action
as closed The owner will remain nigel.
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.