Opened 9 years ago

Closed 9 years ago

#8804 closed defect (fixed)

Video pauses when volume adjusted

Reported by: danielk Owned by: beirdo
Priority: blocker Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Both the audio and video pause when the volume is adjusted since the MythUI merge.

Change History (8)

comment:1 Changed 9 years ago by danielk

Owner: set to markk
Status: newassigned

comment:2 Changed 9 years ago by markk

Status: assignedinfoneeded

Daniel - what video renderer/OSD painter are you using?

OSD performance post merge is now entirely different. For VDPAU, Direct3D9 and OpenGL it will be much faster. For ChromaKey? any differences will be down to Qt painting versus the old OSD painting code. For the blended OSD there will be similar painting differences and potentially a small performance penalty as we paint in '24bit' yuv and convert as needed.

That said, I was pretty careful when writing the software blended code to ensure it optimises wherever possible.

I'm not really sure what else to do or say. The code base is now different.

(are you sure it's not an audio issue given that the 2 merges happened in close proximity)

comment:3 Changed 9 years ago by danielk

Status: infoneededassigned

It's with VDPAU where I'm seeing the bug. Since the merges were in close proximity it may well be audio causing the problem, what kind of logging is required to assess? "-v audio,playback" ?

comment:4 Changed 9 years ago by danielk

And now for something entirely unexpected...

2010-09-02 19:27:23.939 Launching: gnome-screensaver-command --poke >&- 2>&- &
2010-09-02 19:27:23.948 PID 12050: launched
2010-09-02 19:27:23.985 PID 12050: exited: status=0, result=0

Remove gnome-screensaver there is no pause in audio and just a tiny pause in the video.

comment:5 Changed 9 years ago by danielk

Owner: changed from markk to beirdo

comment:6 Changed 9 years ago by beirdo

See [26092] for the backgrounding of the gnome-screensaver-command in myth_system.

comment:7 Changed 9 years ago by beirdo

Status: assignedinfoneeded

Waiting to see if the aforementioned change fixes the reported issue.

comment:8 Changed 9 years ago by danielk

Resolution: fixed
Status: infoneededclosed

I can confirm the fix works.

Note: See TracTickets for help on using tickets.