Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8821 closed patch (fixed)

config directory fails to build using Ubuntu 10.10

Reported by: superm1@… Owned by: Janne Grunau
Priority: minor Milestone: 0.23-fixes
Component: MythTV - General Version: 0.23-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When trying to build the source tree with the patch from 8572 applied, the following error comes up:

make[3]: Leaving directory `/build/supermario-mythtv_0.23.1+fixes25842-0ubuntu1-i386-NqgxkM/mythtv-0.23.1+fixes25842/bindings/perl'
cd python/ && make check
make[3]: Entering directory `/build/supermario-mythtv_0.23.1+fixes25842-0ubuntu1-i386-NqgxkM/mythtv-0.23.1+fixes25842/bindings/python'
python setup.py build
running build
running build_py
running build_scripts
-Wl,-O1 -o python -lQtGui -lQtCore -lpthread
make[3]: Leaving directory `/build/supermario-mythtv_0.23.1+fixes25842-0ubuntu1-i386-NqgxkM/mythtv-0.23.1+fixes25842/bindings/python'
make[2]: Leaving directory `/build/supermario-mythtv_0.23.1+fixes25842-0ubuntu1-i386-NqgxkM/mythtv-0.23.1+fixes25842/bindings'
cd config/ && make check
make[2]: *** No rule to make target `check'make[2]: Entering directory `/build/supermario-mythtv_0.23.1+fixes25842-0ubuntu1-i386-NqgxkM/mythtv-0.23.1+fixes25842/config'
.  Stop.
make[2]: Leaving directory `/build/supermario-mythtv_0.23.1+fixes25842-0ubuntu1-i386-NqgxkM/mythtv-0.23.1+fixes25842/config'
make[1]: *** [sub-config-check_ordered] Error 2
make[1]: Leaving directory `/build/supermario-mythtv_0.23.1+fixes25842-0ubuntu1-i386-NqgxkM/mythtv-0.23.1+fixes25842'
dh_auto_test: make -j1 check returned exit code 2
make: *** [build] Error 29

Attachments (4)

configure_missing_check.patch (330 bytes) - added by superm1@… 9 years ago.
patch to fix problem
configure_missing_check.2.patch (819 bytes) - added by superm1@… 9 years ago.
patch for trunk
configure_missing_check.3.patch (357 bytes) - added by superm1@… 9 years ago.
patch for mythplugins fixes
configure_missing_check.4.patch (357 bytes) - added by superm1@… 9 years ago.
patch for mythplugins trunk

Download all attachments as: .zip

Change History (15)

Changed 9 years ago by superm1@…

patch to fix problem

comment:1 Changed 9 years ago by robertm

Milestone: 0.24unknown
Owner: set to Janne Grunau
Status: newassigned

Note the patch here is actually for the configure file, not for anything called mythtv-fixes, so will not apply to anything in our source. Janne, assigning to you.

Mario, thanks for the patch. Please don't set milestone on our tickets, see the ticket howto for further details.

comment:2 Changed 9 years ago by robertm

(and my bad re the file path, new trac is stripping off the filename in this case, weird)

comment:3 Changed 9 years ago by superm1@…

Sorry on the milestone bit. That above patch is against -fixes, here's the one for -trunk. (Trunk needs it applied to another directory too)

Changed 9 years ago by superm1@…

patch for trunk

comment:4 Changed 9 years ago by superm1@…

Just to be clear here, I didn't randomly decide to go call 'make check'. qmake added a 'check' rule to all of it's Makefile's that were generated. This is likely something new for QT 4.7.

The only reason that these patches were necessary is because those two Makefiles (external and ./configure generated) aren't touched by qmake at all.

Changed 9 years ago by superm1@…

patch for mythplugins fixes

Changed 9 years ago by superm1@…

patch for mythplugins trunk

comment:5 Changed 9 years ago by Janne Grunau

Resolution: wontfix
Status: assignedclosed

what forces you to run make check?

comment:6 Changed 9 years ago by Janne Grunau

bah, missed your update. qmake's generated Makefile adds check target as dependency for all or install target? that is imho a qmake bug and shoud be reported there. I've found nothing in the qt 4.7 docs or changelogs.

comment:7 Changed 9 years ago by superm1@…

It might be a qmake bug, or even a qmake feature - but this is a harmless set of patches that doesn't cause regressions on earlier qmake and fixes it on later. I don't see the problem here with them.

comment:8 Changed 9 years ago by Janne Grunau

(In [25897]) replace mythtv.pro with handwritten Makefile

I was unable to convince qmake to create extra targets within subdir template .pro file. This was required to create version.cpp in mythtv/ instead of each directory using version.cpp. Speedups build and configure. Refs #8821

comment:9 Changed 9 years ago by Janne Grunau

Milestone: unknown0.23-fixes
Resolution: wontfix
Status: closednew

comment:10 Changed 9 years ago by Janne Grunau

Resolution: fixed
Status: newclosed

(In [25902]) add empty check: rules config/Makefile to appease qmake from Qt 4.7

Fixes #8821

comment:11 Changed 9 years ago by superm1@…

re 25897, that fixes mythtv proper nicely. I think there's still a mythplugins component to that to be fixed up in trunk however. The 25902 looks good for fixes.

Note: See TracTickets for help on using tickets.