Opened 10 years ago

Closed 10 years ago

#8827 closed defect (fixed)

change set 25699 removes the teletext menu on channels with teletext

Reported by: leoweppelman at gmail Owned by: markk
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: Unspecified
Severity: medium Keywords:
Cc: Ticket locked: no

Description

I wanted the turn on page 888 on Regie Perrin (BBC1) last night, but the teletext options were gone from the menu. I traced this back to changeset 25699. If I revert the checks on ttm_tracks.empty() in tv_play.cpp to checking 'VBIMode::PAL_TT == vbimode', I get a teletext menu again and I can select the subtitles again.... I don't know if reverting is the correct fix or that the calculation of ttm_tracks is wrong.

I'm running trunk as of 2hours ago...

Attachments (1)

ttx.diff (774 bytes) - added by markk 10 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 10 years ago by robertm

Owner: set to markk
Status: newassigned

comment:2 Changed 10 years ago by robertm

Component: MythTV - GeneralMythTV - Video Playback

comment:3 Changed 10 years ago by anonymous

Can you post a clip somewhere of the first couple of minutes of a recording from BBC1? Should help me figure out where the problem lies. I don't really want to revert r25699 if there is an alternative. thanks, Mark

comment:4 Changed 10 years ago by anonymous

I uploaded it to rapidshare (50sec. clip):

http://rapidshare.com/files/415727902/1006_20100825232000_part.mpg MD5: 5361540812C108294677D15A3D890E1E

comment:5 Changed 10 years ago by anonymous

or svn.mythtv.org:/var/lib/videos/tickets/ticket_8827/1006_20100825232000_part.mpg

Changed 10 years ago by markk

Attachment: ttx.diff added

comment:6 Changed 10 years ago by anonymous

Can you check whether the attached patch fixes the problem for you. I see no reason why it shouldn't but I still can't seem to get a teletext menu on screen from that clip. thanks, Mark

comment:7 in reply to:  6 Changed 10 years ago by anonymous

Replying to anonymous:

Can you check whether the attached patch fixes the problem for you. I see no reason why it shouldn't but I still can't seem to get a teletext menu on screen from that clip. thanks, Mark

Yes, that seems to be working! Note that although page100 is missing from the clip, page888 should be there.... If I start the video, press pause, select teletext, page 888 and continue playing, there really are subtitles. If you want a larger clip as a reference, please say so. I didn't know that it became so easy to share large data files ;-)

comment:8 Changed 10 years ago by markk

Resolution: fixed
Status: assignedclosed

(In [26012]) Fix teletext menus and captions that use the MPEG2VBI stream type (IVTV recordings?).

It looks as if there should also be a fix for enabling and disabling '888' captions directly but I can't get them to turn off afterwards!

Closes #8827

Note: See TracTickets for help on using tickets.