Opened 9 years ago

Closed 9 years ago

#8845 closed defect (fixed)

LiveTV group shown when show recording groups is selected

Reported by: Paul Stuttard <stutty@…> Owned by: stuartm
Priority: minor Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: low Keywords: livetv recording group
Cc: Ticket locked: no

Description

Perhaps should have reopened Ticket #7864. This problem is still present in 0.23-fixes branch, a look at playbackbox.cpp it certainly looks like the logic is wrong. But the logic in this area could probably do with a complete rewrite, a few comments would go amiss either.

There are probably half a dozen ways to fix this discrepancy in the behavior, including the one I have attached, since there are no comments its not obvious what the intended behavior is.

I view the 'LiveTV' recording group as a special case (similar to 'Deleted'), i.e. It should not be classed as a 'Recording Group' in its own right. However the side effect of this is that if you select LiveTV as the Group Filter, and do not have 'Show Titles' or 'Show Categories' selected in the Group View it will not show any programs. Previously if Show LiveTV & Show Recording Groups were selected then all the LiveTV programs would be shown... (bit of a garbled ramble).

Attachments (2)

playbackbox.fixes.diff (1.2 KB) - added by Paul Stuttard <stutty@…> 9 years ago.
Patch for Fixes branch
playbackbox.trunk.diff (1.2 KB) - added by Paul Stuttard <stutty@…> 9 years ago.
Trunk Patch

Download all attachments as: .zip

Change History (5)

Changed 9 years ago by Paul Stuttard <stutty@…>

Attachment: playbackbox.fixes.diff added

Patch for Fixes branch

Changed 9 years ago by Paul Stuttard <stutty@…>

Attachment: playbackbox.trunk.diff added

Trunk Patch

comment:1 Changed 9 years ago by robertm

Owner: set to stuartm
Status: newassigned

comment:2 Changed 9 years ago by stuartm

Milestone: unknown0.24
Status: assignedaccepted
Version: 0.23-fixesTrunk Head

I was only able to reproduce when I used the All Programmes filter.

comment:3 Changed 9 years ago by stuartm

Resolution: fixed
Status: acceptedclosed

(In [26274]) Fix LiveTV recordings showing up when they shouldn't have. Patch from Paul Stuttard. Fixes #8845

Note: See TracTickets for help on using tickets.