Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8849 closed defect (Invalid)

recording description inaccurate when scheduling recording to start early

Reported by: svndotmythtvdotorg1@… Owned by: danielk
Priority: minor Milestone: unknown
Component: MythTV - Scheduling Version: Master Head
Severity: low Keywords:
Cc: Ticket locked: no

Description

When setting a recording rule to schedule recordings to start a few minutes early, the description that is saved with the recording is sometimes the recording of the previous show on that channel.

For example, for this schedule: 2:30 - 3:29 Show 1 3:30 - 4:29 Show 2

After making a recording rule for Show 2 and setting it to start 5 minutes early (i.e. at 3:25) will sometimes cause all recordings for Show 2 to have Show 1's description.

Change History (8)

comment:1 Changed 9 years ago by robertm

Owner: changed from gigem to danielk
Status: newassigned

Random guess that this is related to the pginfo refactor/some of the changes a few weeks ago, reassign if I'm mistaken.

comment:2 Changed 9 years ago by danielk

Status: assignedinfoneeded

I'm going to need more details to reproduce this. I'm seeing the correct programs.

Do any other channels contain different program descriptions but the same callsign?

comment:3 Changed 9 years ago by anonymous

Status: infoneededassigned

Sorry, I've seen this behavior for quite awhile now on about 50% of my recordings, and am just now reporting it.. The most recent affected recordings I have were back on the 24th of August, so I unfortunately do not have schedule info that far back to see exactly where it is pulling the incorrect descriptions from..

Just did an update this week on the trunk, and so far I have not seen any recordings affected. Perhaps was there a fix made between the 24th and this week?

If we keep the ticket open, I'll provide more info as soon as I see another incorrect description after I do some more troubleshooting.

comment:4 Changed 9 years ago by nate <svndotmythtvdotorg1@…>

Ok it recorded another show tonight with an incorrect description.

It looks like it is taking the description of the show directly preceding the show to be recorded. In this case I had it set to start 1 minute early.

This issue might not be related directly to recording, however, because it appears that the guide is showing the incorrect description for the show in question as well. In fact, it appears that it is duplicating the description of the preceding show for the show to be recorded (i.e. for the show 1-2 example above, both shows in the guide have the description of 'show 1'.

This, of course, could be an error directly in the schedule feed as well.. I will look into this and get back to you shortly.

comment:5 Changed 9 years ago by danielk

Status: assignedinfoneeded

How are you getting your scheduling guide data? DataDirect?? XMLTV? EIT?

comment:6 Changed 9 years ago by nate <svndotmythtvdotorg1@…>

I have a subscription to SchedulesDirect?, but I also have the EIT scan box checked (ATSC feed).. I'll uncheck EIT to check if this is causing the problem. Four new shows were just recorded with the same description issue, but I haven't been able to rule out the schedule feed as the culprit yet.

comment:7 Changed 9 years ago by robertm

Resolution: Invalid
Status: infoneededclosed

XML and EIT listings on the same channel are not support, precisely because this kind of thing happens. You use one or the other, not both-- otherwise EIT comes in and overwrites XML schedule data that you are relying on to properly schedule shows. Turning off EIT entirely will solve the issue.

comment:8 Changed 9 years ago by nate <svndotmythtvdotorg1@…>

Hmm. I see. So the EIT scanner is incorrectly updating/overriding the schedules when a program is set to record early. This is in reference to the 'Perform EIT scan' check box when setting up a source feed.

According to the description for the 'Perform EIT scan': "If enabled, program guide data on this source will be updated with data provided by the channels themselves, Over-the-air". This description sounds like the two are allowed to work in consort, with more timely schedules from EIT data overriding schedules with (presumably) more accurate information.

It sounds like the EIT update may be faulty from your description, and the scan is incorrectly updating the listings when programs are scheduled to start early.

So I must ask, is this perhaps a bug with how the EIT update is updating schedules when a program is scheduled to record early? If so, could the EIT update procedure be changed to correctly handle this situation? Or is EIT update working in consort with a regular feed completely unsupported/faulty, now and in the future? If the latter is correct, perhaps the 'EIT Scan' description could be changed to express this?

Thank you for all your help. I will uncheck the 'Preform EIT scan' option for this source and see if the problem resolves.

Note: See TracTickets for help on using tickets.