Opened 9 years ago

Closed 9 years ago

#8850 closed defect (Fixed)

SVQ3 (Sorenson 3) Codec Fails on Multi-Core Systems

Reported by: pebender@… Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: 0.23-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

When attempting to use MythVideo? to play a MOV file containing SVQ3 encoded video, the internal player fails (on MythTV 0.22 fixes mythfrontend crashes and on MythTV 0.23 mythfrontend returns to the video selection screen). As far as I can tell, the problem is that the SVQ3 codec does not suppport multi-thread decoding (and exits with a return value of -1) yet MythTV configures for multi-thread decoding when there are multiple cores available anyway.

I have attached patches for MythTV 0.22 fixes, MythTV 0.23 fixes and trunk. They force threading to 1 when the codec is SVQ3. This may not be the best fix, but I did it because it works for me on my MythTV 0.23 system (I have tested it on MythTV 0.23 fixes not on MythTV 0.22 or MythTV trunk).

Attachments (4)

mythtv-trunk-codec_id_svq3_fix.patch (578 bytes) - added by pebender@… 9 years ago.
mythtv-0.23-codec_id_svq3_fix.patch (671 bytes) - added by pebender@… 9 years ago.
mythtv-0.22-codec_id_svq3_fix.patch (671 bytes) - added by pebender@… 9 years ago.
mythtv-trunk-codec_id_svq3_fix-v2.patch (583 bytes) - added by anonymous 9 years ago.

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by pebender@…

Changed 9 years ago by pebender@…

Changed 9 years ago by pebender@…

comment:1 Changed 9 years ago by robertm

Status: newassigned

Changed 9 years ago by anonymous

comment:2 Changed 9 years ago by robertm

Resolution: Fixed
Status: assignedclosed

This appears to be upstream bug:

https://roundup.libav.org/issue1292

which is fixed.

Tested against multiple samples from:

http://samples.mplayerhq.hu/V-codecs/SVQ3/

with multi-CPU software decode, and no crashes in sight.

Note: See TracTickets for help on using tickets.