Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#8874 closed defect (fixed)

Commflag icon incorrectly displayed

Reported by: Jim Stichnoth <stichnot@…> Owned by: stuartm
Priority: minor Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The "Commercials are being flagged" icon in the PBB appears to be set whenever there is a cutlist present, not just when commflagging is active. To reproduce, edit a recording, add a cutlist, and refresh the Watch Recordings list.

Change History (6)

comment:1 Changed 9 years ago by robertm

Owner: set to stuartm
Status: newassigned

comment:2 Changed 9 years ago by stuartm

Status: assignedinfoneeded
Version: UnspecifiedTrunk Head

Can you please tell us which theme you are using? I'm unable to reproduce with Terra.

comment:3 Changed 9 years ago by Jim Stichnoth <stichnot@…>

Status: infoneededassigned

I went through the themes on my system. Here's a summary:

Arclight: Many status icons are missing for some reason, so I can't tell.

Childish: "Commercials are being flagged" icon is missing.

Blue Abstract, Graphite, LCARS, Mythbuntu, MythCenter?-wide, TransBlue?: Has the behavior described.

Metallurgy, Terra: Doesn't have the behavior described.

Also, in several of the themes, the "Commercials are being flagged" icon is never active even during commflagging. One example is Graphite. There are others, but I didn't rigorously note which.

comment:4 Changed 9 years ago by sphery

FWIW, each icon a theme displays requires the themer to dedicate an empty area of the screen for that icon. Theme authors are allowed to decide which icons they want to support. So "missing" simply means that the theme author chose not to dedicate space for that icon.

The HELP key (by default F1) can be used to bring up the help dialog in Watch Recordings that shows which icons the themer decided to support/show.

comment:5 Changed 9 years ago by stuartm

Resolution: fixed
Status: assignedclosed

(In [26200]) The processing icon was mistakenly associated with the editing flag and not the commprocessing flag. Fixes #8874

comment:6 Changed 9 years ago by stuartm

Milestone: unknown0.24
Note: See TracTickets for help on using tickets.