Opened 9 years ago

Closed 9 years ago

#8904 closed defect (fixed)

mythgallery segfault if startup folder is empty

Reported by: yianniv Owned by: beirdo
Priority: minor Milestone: 0.24
Component: Plugin - MythGallery Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Well, as it says. I am testing a new (test) installation. The mythgallery plugin segfaults unless there is at least one picture in its startup folder. I can reproduce it easily by removing and adding a picture.

MythTV Version : 26179M MythTV Branch : trunk Network Protocol : 61 Library API : 0.23.20100905-1 QT Version : 4.6.0 Options compiled in:

linux release using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_dvb using_frontend using_hdpvr using_iptv using_ivtv using_mheg using_opengl_video using_opengl_vsync using_qtdbus using_qtwebkit using_v4l using_x11 using_xrandr using_xv using_xvmc using_xvmc_vld using_xvmcw using_bindings_perl using_bindings_python using_mythtranscode using_opengl using_ffmpeg_threads using_live using_mheg

Change History (3)

comment:1 Changed 9 years ago by beirdo

Status: newassigned

comment:2 Changed 9 years ago by beirdo

Milestone: unknown0.24

comment:3 Changed 9 years ago by beirdo

Resolution: fixed
Status: assignedclosed

(In [26214]) Displays the "no pictures in this directory" rather than crashing on entering mythgallery with an empty gallery directory.

Fixes #8904

Note: See TracTickets for help on using tickets.