Opened 9 years ago

Closed 9 years ago

#8906 closed defect (fixed)

OSD notification of failed tune no longer displayed

Reported by: robertm Owned by: markk
Priority: major Milestone: 0.24
Component: MythTV - Video Playback Version: Master Head
Severity: high Keywords:
Cc: Ticket locked: no

Description

With current trunk, I am no longer able to see the "You should have received a channel lock by now" OSD message when a Live TV channel tune fails. On a nonexistent (VOD) or off-air channel, the screen just hangs on black and eventually fails back to the menu, usually with "Video frame buffering failed too many times."

I am suspecting this is part and parcel of the OSD merge or the OSD timeout changes, but I'm setting milestone to .24 as it leaves the user unable to ever start Live TV again without going into mythtv-setup and resetting the starting channel. An ideal solution would restore the proper function of this popup and incorporate some form of Mark Buechler's "Only save the starting channel when it actually tunes" patch from #4807.

Change History (4)

comment:1 Changed 9 years ago by robertm

This may also be caused by the signal monitor changes, so I may have assigned this in error (but hopefully we can figure out who best to handle it).

comment:2 Changed 9 years ago by robertm

Status: newassigned

comment:3 Changed 9 years ago by markk

Status: assignedaccepted

comment:4 Changed 9 years ago by markk

Resolution: fixed
Status: acceptedclosed

(In [26327]) Fix the channel change timeout popup.

I suspect this was broken by r25543 (Signal monitor changes) and if so there are sections of code that need to be stripped out as the behaviour now appears to be triggered by events from the signal monitor and not by the timer directly.

Closes #8906.

As an aside, the message or the themes probably need to be adjusted as presentation is generally a mess when using XVideo.

Note: See TracTickets for help on using tickets.