Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#8927 closed defect (Fixed)

Trunk unable to playback MPEG4 files created by mythtranscode

Reported by: Kenni Lund [kenni a kelu dot dk] Owned by: Janne Grunau
Priority: major Milestone: 0.24
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: yes

Description (last modified by Kenni Lund [kenni a kelu dot dk])

(new ticket created, as #8864 seemed to be the same issue, but wasn't in the end)

Trunk have issues to playback MPEG4 files, at least (but perhaps not limited to) MPEG4 files created by mythtranscode.

I've uploaded a 20MB sample here: https://docs.google.com/leaf?id=0B-_nZameGeN-NTY5NGVjOGYtMDYzNS00Zjc4LWI3OGYtOTk2MzU4MzczZmVj&hl=da&authkey=CJv8zvAO

The sample plays with mythavtest on 0.23-fixes, but will fail 20-90% of the time on trunk r26520 (both VDPAU and Xv). The video playback will freeze on one of the first frames, while the audio will continue to play correctly. Doing a fast forward or rewinding causes the screen to turn grey. Just like 0.23-fixes, mplayer doesn't have any issues with the sample. I'm attaching "mythavtest -v playback" logs from trunk.

All of my recordings are automatically transcoded by MythTV from MPEG2 (Hauppauge HW encoder) into MPEG4 - the sample comes from one of these files.

Attachments (1)

playback_verbose_26203.log (34.8 KB) - added by Kenni Lund [kenni a kelu dot dk] 9 years ago.
mythvavtest -v playback

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

Attachment: playback_verbose_26203.log added

mythvavtest -v playback

comment:1 Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

Status: newassigned

comment:2 Changed 9 years ago by paul.r.thompson@…

I have the same thing occurring on my system. The system previously was playing back fine on 0.23. I have verified that the problem is with the playback and not the recording because

1) Recordings recorded with 0.23 show this issue when played back with 0.24 2) Recordings recorded with 0.24 show fine when played with VLC (but not with MythTV 0.24)

System details: Separate backend and frontend Backend video source is a HD-PVR recording 1080i Video card is a Nvidia 280GTX System is from the Mythbuntu PPA 0.24 - currently at r26423 If it means anything, the current playback config is vdpau, one CPU, 2x temporal, fallback to 1x temporal

I will attach a log of mythvavtest -v playback output

comment:3 Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

Description: modified (diff)
Ticket locked: set

paul, I don't see anything in your logs indicating that you have the same issue. I'm not saying that you don't have a similar issue, just that it's not the same issue handled by this ticket. I've extended the description to be more specific about the issue.

Anyway, "me too" messages doesn't help the developers and are forbidden, please read the TicketHowTo at http://svn.mythtv.org/trac/wiki/TicketHowTo

comment:4 Changed 8 years ago by beirdo

Turns out that reverting [25805] fixes this, but will require reopening #3001

comment:5 Changed 8 years ago by Janne Grunau

Resolution: Fixed
Status: assignedclosed

(In [27132]) Revert [25805], the fix for our workaround created playback problems

Fixes #8927, Reopens #3001

comment:6 Changed 8 years ago by Janne Grunau

(In [27134]) backports [27132] from trunk

Revert [25805], the fix for our workaround created playback problems

Fixes #8927, Reopens #3001

Note: See TracTickets for help on using tickets.