Opened 14 years ago

Closed 13 years ago

#897 closed enhancement (wontfix)

RealTek ALC880 Issues (Audio Buffer Overflow)

Reported by: ian.bonham@… Owned by: Robert Kulagowski
Priority: trivial Milestone: unknown
Component: mythtv Version: head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Hi Robert,

Just a quick note you may want to include mate, as I have had this problem and spent hours on it. I was unable to find anything on the web about it, so the cure was trial and error (for my setup anyway), and it seems it's a growing problem.

I have an MSI mobo, 915 series, with a P43.2ghz and 512gb Ram. When I tried to play or record live TV I had major issues with stuttering video and choppy sound. This was in Myth0.18.1 on Debian (KnoppMyth?) Kernel 2.6.13.2-chw-3 #1 SMP. I was able to recreate the issue using cat /dev/video0 > ./test.mpg, so I knew it wasn't down to Myth as the stream dump (from a Hauppauge PVR150) was knackered as well. However, Myth was outputting bugs of "Prebuffering Pause" and "Audio Buffer Overflow,Audio Data Lost!". It seems a lot of people are having the same prob. It seems it was the sound so upgraded to Alsa1.0.11rc1, which reportedly solved a lot of the ALC880 problems. Still the same tho, so I downloaded RealTek?'s driver from their site. Still the same.

So I started to look at OSS. Reading their Doc's it states their driver works with all AC97 chipsets. This made me think, in the BIOS there is an option to switch the onboard sound between Disabled/AC97/Azalia. I checked my BIOS and it was in Azalia mode. I switched it back to AC97, then brought Debian up and ran alsaconf again just to check any settings were reset.

MythTV and recording now works perfectly. It seems there is a bug somewhere in the ALSA drivers for the Azalia mode of the ALC880. Running it in AC97 mode means alsa can talk perfectly to it. This simple fix suddenly got Myth working perfectly and I'm really impressed with it. Glad I wiped M$'s MCE now! It's worth noting that I didn't try the OSS drivers in the end. As of today (30/12/05) it's still noted on OSS docs as experimental, and as alsa runs nicely with AC97 mode I didn't bother opening the OSS can of worms!

Hope that helps someone else out, dunno if you want to stick it in the docs somewhere, but a simple BIOS tweak saved my buying an SB Live! :)

Happy New Year to all the Myth team, thanks for a great project,

Bon

Change History (3)

comment:1 Changed 14 years ago by danielk

Milestone: unknown
Owner: changed from Isaac Richards to Robert Kulagowski
Priority: majortrivial
Severity: mediumlow
Type: patchenhancement
Version: head

Something for the FAQ in the documentation?

comment:2 Changed 14 years ago by Robert Kulagowski

Status: newassigned

May be something more appropriate for the Wiki, once it's turned up.

I'm going to leave this open for now, but won't add it to the HOWTO.

comment:3 Changed 13 years ago by Robert Kulagowski

Resolution: wontfix
Status: assignedclosed

The wiki is now operational; if you feel that this information is important, please post it there.

Note: See TracTickets for help on using tickets.