Opened 10 years ago

Closed 9 years ago

#8979 closed defect (Fixed)

[CRASH] LiveTV changing channels cause fe crash

Reported by: warpme@… Owned by: cpinkham
Priority: minor Milestone: 0.25
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Scenario to reproduce:

1.lauch LiveTV
2.start to change channels

3.after 2-10 changes FE usually crashes

fe (trunk 26423) logs attached

Attachments (3)

mythfrontend-fe-test.log.zip (8.9 KB) - added by warpme@… 10 years ago.
FE log
logs.tar.gz (23.6 KB) - added by warpme@… 10 years ago.
FE/BE logs
myth_debug.tar.gz (36.8 KB) - added by warpme@… 10 years ago.
FE backtrace

Download all attachments as: .zip

Change History (23)

Changed 10 years ago by warpme@…

FE log

comment:1 Changed 10 years ago by Nicolas Riendeau

Status: newinfoneeded_new

warpme, are you still having that problem?

comment:2 Changed 10 years ago by anonymous

I'm seeing this here too. My current suspicion is that the backend is expiring a bunch of short live tv segments at the same time and this is somehow blocking access to the new live tv recording.

Can you attach the output of both mythfrontend and mythbackend with -v playback,file verbosity

Also, what tuners are you using?

comment:3 Changed 10 years ago by markk

Status: infoneeded_newnew

Just to clarify the tuner info, I'm also wondering whether this is some sort of lock up with the ivtv (pvr-150 etc) driver.

comment:4 Changed 10 years ago by beirdo

Status: newinfoneeded_new

comment:5 Changed 10 years ago by warpme@…

Hi,
Sorry for late replay (I was on business trip)
Pls find FE/BE logs. My sys has 2XDVB-S2 + 1xDVB-T tuners. FE/BE under test was SVN26493.
br

Changed 10 years ago by warpme@…

Attachment: logs.tar.gz added

FE/BE logs

comment:6 Changed 10 years ago by robertm

Status: infoneeded_newnew

comment:7 Changed 10 years ago by robertm

Milestone: 0.24unknown
Priority: majorminor
Severity: highmedium

warpme, you have been around long enough to know that you are not to set milestones, priorities, or severities on tickets.

comment:8 Changed 10 years ago by robertm

Status: newassigned

comment:9 Changed 10 years ago by robertm

Status: assignedinfoneeded

Does anyone have a backtrace of this crash?

comment:10 Changed 10 years ago by warpme@…

Unfortunately for me it is not easy to do backtrace of crash, as my FE is running on minimal, remote booted environment. If nobody else will help here - I will try install mythbuntu on VM and try to reproduce crash with backtrace. Unfortunately lack of time not helps here :-( Any hints helpful to minimize time spent on backtrace creation are well appreciated.

comment:11 Changed 10 years ago by robertm

warpme,

As you are the original reporter, unfortunately the responsibility is on you to be able to produce a backtrace. Please attach at your earliest convenience. See section 22 of the manual and the wiki page on debugging.

comment:12 Changed 10 years ago by warpme@…

Fortunatelly my friend help me with quick setup gdb-equipped environment. Here are backtraces for frontend. FE was on 26655. br

Changed 10 years ago by warpme@…

Attachment: myth_debug.tar.gz added

FE backtrace

comment:13 Changed 10 years ago by robertm

Owner: changed from Janne Grunau to markk
Status: infoneededassigned

Crashing on MythPlayer::GetEncodingType?. Unable to get the decoder?

comment:14 Changed 10 years ago by robertm

Note that there are two issues here-- the fact that we are calling GetEncodingType? on a null recording (which is just the symptom causing the segfault) and an apparent RingBuffer? problem where we mercilessly are attempting to read after some sort of communications or socket error and safe_read is failing again and again. This may be a multiple-assignee bug.

comment:15 Changed 10 years ago by markk

The NULL pointer crash was fixed in r26685. As robertm has already mentioned, it is probably a symptom of the overall problem rather than the cause.

comment:16 Changed 10 years ago by warpme@…

Robert, Mark

Thx. No more FE crashes. We can close ticket. Unfortunately Mark is right: FE crash is a symptom more general problem with my LiveTV. I'll move to commits mailing-list for details. thx

comment:17 Changed 10 years ago by robertm

Owner: changed from markk to cpinkham

Chris, reassigning to you for the rest, hoping you can look at the safe_read issue in the FE log and determine if there's a RB bug there.

comment:18 Changed 9 years ago by beirdo

Summary: LiveTV changing channels cause fe crash[CRASH] LiveTV changing channels cause fe crash

comment:19 Changed 9 years ago by warpme@…

Hi, After switching to latest master I didn't observe this issue on 24/7 working production system. From my perspective we can close this ticket with status resolved.

comment:20 Changed 9 years ago by beirdo

Milestone: unknown0.25
Resolution: Fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.