Opened 14 years ago

Closed 14 years ago

#898 closed defect (fixed)

problems doing a channel scan on a newly configured dvb-s card

Reported by: simon@… Owned by: danielk
Priority: minor Milestone: 0.19
Component: dvb Version: head
Severity: low Keywords: dvb scan
Cc: Ticket locked: no

Description

in mythtv-setup i added a new card (a Nexus-S). then i went into input connections and tried to do a channel scan on the newly added card. there was a drop down showing the two (previously existing) tuner cards and without realising it, when i said scan existing transports, it started scanning on analogue tuners.

if however, i added the tuner card, did the video source assignment and then exited mythtv-setup and went back in, the correct DVB:0 was set up and i could do a channel scan.

this seems to be one of a class of problems where changes to settings in one part of the program are not recognised in others. a previous example was having to leave mythfrontend for mythvideo file type assignments to be recognised. but then again, i could be talking complete rubbish.

Change History (2)

comment:1 Changed 14 years ago by danielk

I can reproduce this.

As you said, it looks like the settings aren't getting propigated.

I'll take care of this after #868, and #843, unless someone makes a patch for this before then.

comment:2 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [8480]) Fixes #898. Save cardinput before doing scan.

Note: See TracTickets for help on using tickets.