Opened 9 years ago

Closed 9 years ago

#8980 closed defect (Invalid)

MythXML guide doesn't reflect recently added recording rules

Reported by: foobum <foobum@…> Owned by: dblain
Priority: minor Milestone: unknown
Component: MythTV - General Version: Master Head
Severity: medium Keywords: getprogramguide fromprogramquery
Cc: Ticket locked: no

Description

This appears to be because, since r24694 (ProgramInfo refactor), FromProgramQuery() (called from LoadFromProgram(), both in programinfo.cpp) executes a query which does a join with oldrecorded (as opposed to record presumably). So, rules that haven't resulted in a recording yet don't get the correct RecordingType, etc. The guide XML therefore doesn't reflect the fact that a recently scheduled program is scheduled for recording.

Change History (3)

comment:1 Changed 9 years ago by danielk

Milestone: unknown0.24
Owner: set to danielk
Status: newaccepted

comment:2 Changed 9 years ago by danielk

Milestone: 0.24unknown
Owner: changed from danielk to dblain
Status: acceptedassigned

It appears this is not a PI refactor regression. The query is unchanged since before the refactor (it has simply been moved from programlist.cpp to programinfo.cpp) I also checked the query indexes in LoadFromProgram? and they matched the comments.

comment:3 Changed 9 years ago by robertm

Resolution: Invalid
Status: assignedclosed

Closing since MythXML no longer exists (and to the best of my knowledge, the Guide service should produce working output)

Note: See TracTickets for help on using tickets.