Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 4 years ago

Closed 3 years ago

Last modified 15 months ago

#8990 closed defect (Fixed)

Recorded Programs page "Warning"

Reported by: MarcT <myrdhn@…> Owned by: kormoc
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

On the Recorded Programs page you get a "Warning: No matching programs found. Showing all programs."
I get this error when I first click on the Recorded Programs link as well as any time I select any program in the Show recordings dropbox.

Attachments (0)

Change History (9)

comment:1 Changed 4 years ago by knight

  • Status changed from new to infoneeded_new

MarcT, I can't replicate this problem, if you update to the latest revision of Trunk do you still have that problem?

comment:2 Changed 4 years ago by MarcT <myrdhn@…>

I was seeing this with both 26008 and 26371. Updated the entire system to 26542 and now I am nolonger seeing this. Looks like it may have either been outright fixed, or another fix resolved this as well.

comment:3 Changed 4 years ago by knight

  • Resolution set to Fixed
  • Status changed from infoneeded_new to closed

Thank you for reporting back MarcT!

comment:4 Changed 4 years ago by George Poulson <george.poulson@…>

  • Resolution Fixed deleted
  • Status changed from closed to new

I've just encountered this error with trunk 26766.

It happened when I deleted (via MythWeb) some old recordings which were in the 'LiveTV' group.

I was previously shown an option to select a group via a dropdown - All Programmes (x+y) or Recorded Programmes(x) or LiveTV(y).

Now all the LiveTV programmes are gone there is no dropdown to select group ('cause there is only one group!) and I just see one 'Show Recordings' dropdown. Selecting anything here results in the same error box as above. It's also shown when first going to the 'recorded programmes'page.

comment:5 Changed 4 years ago by George Poulson <george.poulson@…>

Just updating to say that now that I have some recordings back in the 'LiveTV' group - and therefore the "show groups" dropdown is now displayed again - the problem has cleared.

It seems that as long as there is content in both recording groups the second 'Show Recordings' dropdown also works and filters the recordings correctly with no errors.

comment:6 Changed 3 years ago by robertm

  • Status changed from new to assigned

comment:7 Changed 3 years ago by kormoc

  • Resolution set to Fixed
  • Status changed from assigned to closed

Fixed in c1ef027

comment:8 Changed 16 months ago by HW <winkler@…>

Hello,

I have a regression of this bug in Mythweb 0.26. Here is the output from mythfrontend --version:

MythTV Version : v0.26.0-66-gb563d7f
MythTV Branch : fixes/0.26
Network Protocol : 75
Library API : 0.26.20120822-1
QT Version : 4.8.1
Options compiled in:

linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcec using_libcrypto using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_live using_mheg using_libass using_libxml2

And from mythbackend --version

MythTV Version : v0.26.0-66-gb563d7f
MythTV Branch : fixes/0.26
Network Protocol : 75
Library API : 0.26.20120822-1
QT Version : 4.8.1
Options compiled in:

linux profile use_hidesyms using_alsa using_oss using_pulse using_pulseoutput using_backend using_bindings_perl using_bindings_python using_bindings_php using_crystalhd using_dvb using_firewire using_frontend using_hdhomerun using_ceton using_hdpvr using_iptv using_ivtv using_joystick_menu using_libcec using_libcrypto using_libdns_sd using_libxml2 using_lirc using_mheg using_opengl_video using_qtwebkit using_qtscript using_qtdbus using_v4l2 using_x11 using_xrandr using_xv using_bindings_perl using_bindings_python using_bindings_php using_mythtranscode using_opengl using_vaapi using_vdpau using_ffmpeg_threads using_live using_mheg using_libass using_libxml2

When I am in mythweb and I navigate to Recorded Programs I immediately receive the alert:

"Warning:
No matching programs found.
Showing all programs."

And the alert is shown again if I attempt to select any show from the dropdown menu. It is not possible to successfully view the recorded programs for a particular show. This is in Ubuntu 12.04.1 LTS with Mythbuntu. Thanks.

comment:9 Changed 15 months ago by verycoldpenguin@…

I am seeing this toooo
In function: public function queryProgramRows($query = null, $offset = 1)

This $records = $this->sendCommand($query);
returns only:

UPDATE_FILE_SIZE 59340 2013-01-29T02:09:00Z 0

This worryingly looks like #11316 again, currently I am not running that patch (to confirm), and my slave is recording.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.