Opened 9 years ago

Closed 9 years ago

#8996 closed defect (Invalid)

wrong lpcm sound channel assignments

Reported by: anonymous Owned by: JYA
Priority: trivial Milestone: unknown
Component: MythTV - Audio Output Version: Master Head
Severity: low Keywords:
Cc: Ticket locked: yes

Description

I've test TrueHD with a testmovie from dolby labs. But myth lpcm doesn't match the audio channel.

Center come from leftsuround. Rightsuround doesn't work. Leftsuround come from center. LFE doesn't work.

And a other problem. If I select lpcm dts-hd with 7ch core doesn't work. It is possible to disable lpcm for non hd?

Attachments (3)

dts-hd_with_lpcm_disable.log (20.4 KB) - added by anonymous 9 years ago.
play DTS-HD lpcm disable
dts-hd_with_lpcm_enable.log (19.9 KB) - added by anonymous 9 years ago.
DTS-HD with lpcm enable
truehd.log (23.7 KB) - added by anonymous 9 years ago.
truehd playback

Download all attachments as: .zip

Change History (13)

comment:1 Changed 9 years ago by robertm

Milestone: 0.24unknown
Priority: majortrivial
Severity: mediumlow
Status: newinfoneeded_new

Please see the ticket howto, do not set priority or milestone. Can you provide the movie to test against?

DTS-HD is unsupported in ffmpeg (and thus in myth) anyway, all it does is strip out the DTS core, which only supports up to 5.1 channels of audio. Thus, there is no such thing as "LPCM DTS-HD" or a 7 channel core.

Also, need -v audio logs.

Changed 9 years ago by anonymous

play DTS-HD lpcm disable

Changed 9 years ago by anonymous

Attachment: dts-hd_with_lpcm_enable.log added

DTS-HD with lpcm enable

Changed 9 years ago by anonymous

Attachment: truehd.log added

truehd playback

comment:2 Changed 9 years ago by anonymous

sorry for my mistake by creating this ticket, thank you it is processed anyway

I've attach requested log, plus 2 logs for my DTS HD problem.

I know that myth (ffmeg) not support DTS HD. But e.g. "The Transporter" has DTS-ES as DTS core, this say myth and my av-reciever too. But if I enable lpcm with 7.1 output I hear nothing (0 Channel audio?)

comment:3 Changed 9 years ago by robertm

Status: infoneeded_newassigned

comment:4 Changed 9 years ago by JYA

Status: assignedinfoneeded

Please provide a sample. Those logs shows that your ALSA audio buffer is set too low too play those files.

Increase it (echo 512 | sudo tee /proc/asound/card0/pcm3p/sub0/prealloc).

Other than that, there's no error showing up in the log ; and you should hear something.

Does your TV or Amp supports 7.1 LPCM ?

comment:5 Changed 9 years ago by JYA

Resolution: Invalid
Status: infoneededclosed

I see no error in the DTS passthrough log either. More likely a local problem with your amplifier or TV not support LPCM audio.

Uncheck LPCM.

comment:6 Changed 9 years ago by anonymous

my av reciever should support lpcm up to 192k.

truehd channels not mached, please test it with "Dolby TrueHD Channel Check (Lossless)" from http://www.demo-world.eu/trailers/high-definition-trailers.php, sorry to forget it in my last comment.

normal dts passtrough work, but if i enable lpcm and 7.1 output dts-es doesn't work. "echo 512 | sudo tee /proc/asound/card0/pcm3p/sub0/prealloc" not help :(.

comment:7 Changed 9 years ago by anonymous

Resolution: Invalid
Status: closednew

comment:8 Changed 9 years ago by robertm

Resolution: Invalid
Status: newclosed
Ticket locked: set

reopening a ticket with no additional comment or debug info is unacceptable.

comment:9 Changed 9 years ago by robertm

Resolution: Invalid
Status: closednew

comment:10 Changed 9 years ago by robertm

Resolution: Invalid
Status: newclosed
Note: See TracTickets for help on using tickets.