Opened 9 years ago

Closed 9 years ago

#9005 closed defect (Fixed)

mythbackend segfault

Reported by: Free Denizen <freedenizen@…> Owned by: beirdo
Priority: critical Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description (last modified by beirdo)

I'm not sure of the trigger for the crash, it seems to happen randomly, but it does not occur when running under gdb. Attaching backtrace from a core dump. Running trunk rev 26497 The only thing I see in the logs are:

*** glibc detected *** /usr/local/bin/mythbackend: corrupted double-linked list: 0xa5e19e10 ***
======= Backtrace: =========
/lib/libc.so.6(+0x6c534)[0xb49e6534]
/lib/libc.so.6(+0x6ca92)[0xb49e6a92]
/lib/libc.so.6(+0x6eab6)[0xb49e8ab6]
/lib/libc.so.6(__libc_malloc+0x5e)[0xb49eae5e]
/usr/lib/qt4/libQtCore.so.4(_Z7qMallocj+0x1e)[0xb4d46634]
/usr/lib/qt4/libQtCore.so.4(_ZN7QString17fromLatin1_helperEPKci+0x3f)[0xb4d91689]
/usr/lib/qt4/libQtCore.so.4(_ZN7QString16fromAscii_helperEPKci+0xd9)[0xb4d9833b]
/usr/local/bin/mythbackend(_ZN7QStringC1EPKc+0x19)[0x807f317]
/usr/local/lib/libmythupnp-0.24.so.0(_ZN4SSDP11ProcessDataEP13MSocketDevice+0xcb)[0xb6934741]
/usr/local/lib/libmythupnp-0.24.so.0(_ZN4SSDP3runEv+0x1ea)[0xb69356a8]
/usr/lib/qt4/libQtCore.so.4(+0x637b5)[0xb4d4b7b5]
/lib/libpthread.so.0(+0x666f)[0xb4be266f]
/lib/libc.so.6(clone+0x5e)[0xb4a4b95e]

Followed by the memory map, please let me know if that would be useful to attach. I'm also seeing previewgen segfaulting as well. It is possible that this is just an error on my machine but if so I've been unable to locate the cause.

Attachments (1)

mythtv_backtrace.txt (20.6 KB) - added by Free Denizen <freedenizen@…> 9 years ago.

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by Free Denizen <freedenizen@…>

Attachment: mythtv_backtrace.txt added

comment:1 Changed 9 years ago by robertm

Owner: set to beirdo
Status: newassigned

comment:2 Changed 9 years ago by beirdo

Description: modified (diff)

comment:3 Changed 9 years ago by Free Denizen <freedenizen@…>

As a note, I noticed #9024 was closed as a dupe of this, I am running gentoo as was the reporter in that ticket as well. Although I'm not running any gentoo specific patches, perhaps this is YAGSE (Yet Another Gentoo Specific Error)?

comment:4 Changed 9 years ago by beirdo

Milestone: unknown0.24
Priority: minorcritical

comment:5 Changed 9 years ago by beirdo

(In [26586]) In DeleteUPnP, always cleanup the UPnP structure unless it was passed in to a call to Init(), in which case, it is the caller's responsibility. At worst, this is just a minor memory leak. At best, it will fix the strange SSDP crashes. Refs #9005.

I will let this soak for a bit to see if it is the sum total of the issue.

comment:6 Changed 9 years ago by beirdo

Resolution: Fixed
Status: assignedclosed

I am going to close this ticket at this time. It seems to be working now. If this particular crash, or the other one (likely related) in the KickDatabase? rears its ugly head again, please re-open and add a new backtrace of the issue.

Note: See TracTickets for help on using tickets.