Opened 9 years ago

Closed 9 years ago

#9070 closed defect (Fixed)

Mythmusic playback fails

Reported by: bhuffman@… Owned by: paulh
Priority: minor Milestone: 0.24
Component: Plugin - MythMusic Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

See attached frontend.log

Attachments (2)

frontend.log (13.5 KB) - added by bhuffman@… 9 years ago.
frontend.2.log (17.1 KB) - added by bhuffman@… 9 years ago.
Frontend log with -v playback

Download all attachments as: .zip

Change History (9)

Changed 9 years ago by bhuffman@…

Attachment: frontend.log added

comment:1 Changed 9 years ago by robertm

Status: newinfoneeded_new

Can you please be much more verbose? It makes it a lot easier to fix tickets when there's at least *some* description of the problem.

comment:2 Changed 9 years ago by bhuffman@…

Sorry. I enter mythmusic, and everything looks fine - I see the list of songs, it picks the song it will play, and it even enters the visualizer, but I hear no audio. Audio works fine in other sections of myth (recordings, video, etc.) The only other sign of problems is that there doesn't appear to be any time information (no song length, progress bar isn't moving, etc.) It appears to be related to these two lines in the log file:

[flac @ 0xb172a60] Estimating duration from bitrate, this may be inaccurate 88 2010-10-07 22:23:34.460 Read frame failed

comment:3 Changed 9 years ago by paulh

Please attach a log created with mythfrontend -v playback

Changed 9 years ago by bhuffman@…

Attachment: frontend.2.log added

Frontend log with -v playback

comment:4 Changed 9 years ago by bhuffman@…

I think this may have been due to files that were ripped incorrectly. At least in the last log, the file that it tries to play was only 86 bytes long. I've removed those files and my other files are playing. The only possible issue is that it didn't seem like it would recover after that initial bad file, b/c I know I'd tried to skip to other files and they also didn't play.

comment:5 Changed 9 years ago by paulh

Status: infoneeded_newassigned

OK I can also reproduce the getting stuck on a bad file bug.

It's nothing to do with the bug but the log is showing you still have a old version of libmythmovies.so in your plugin directory which myth is trying to load. It's best to delete that otherwise you could have some strange unexplained crashes especially when the FE is exiting if my experience is anything to go by. It will probably also fix the "LookupUDN()- bad device type , not enough tokens" errors in the logs.

The "Failed to create OpenGL texture" errors are again nothing to do with this bug but could indicate a problem with your OpenGL setup. You could try one of the visualizers like AlbumArt?, Spectrum or StereoScope? which don't use OpenGL to see if they go away.

comment:6 Changed 9 years ago by paulh

Milestone: unknown0.24
Version: UnspecifiedTrunk Head

comment:7 Changed 9 years ago by paulh

Resolution: Fixed
Status: assignedclosed

(In [26741]) MythMusic: Make sure the avfdecoder dispatches a DecoderEvent::Error event after any errors. This allows any listeners like the miniplayer or the playbackbox to display an error message to the user and to make sure they reset themselves to a stopped state.

This also converts the error popup dialog which is shown while the miniplayer is visible or while playing in the background to a mythui one.

Fixes #9070.

Note: See TracTickets for help on using tickets.