Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9075 closed patch (Fixed)

Fanart only works one time when not using storage groups

Reported by: Jonatan <mythtv@…> Owned by:
Priority: minor Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The returned string from toLocalDir(ArtworkType? t) in in mythtv/programs/mythfrontend/playbackboxhelper.cpp is empty for the second and subsequent calls, leading to fanart etc not being found.

The cause is that the kFanDir, kBannerDir, kCoverDir variables are not declared as static.

Attachments (1)

toLocalDir.patch (492 bytes) - added by Jonatan <mythtv@…> 9 years ago.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by Jonatan <mythtv@…>

Attachment: toLocalDir.patch added

comment:1 Changed 9 years ago by robertm

Resolution: Fixed
Status: newclosed

(In [26717]) Fix lookups of artwork in local pathc after the first by declaring directory paths as static. Patch from Jonatan. PS, stop using local dirs. That ship is sinking. Fixes #9075.

comment:2 Changed 9 years ago by robertm

Milestone: unknown0.24
Note: See TracTickets for help on using tickets.