Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9113 closed defect (Fixed)

AutoExpire: ERROR: Filesystem Info cache is empty

Reported by: klaas.de.waal@… Owned by: cpinkham
Priority: minor Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: low Keywords: AutoExpire error message
Cc: Ticket locked: no

Description

The following error message is always generated by mythbackend at the start:

2010-10-18 19:52:48.706 AutoExpire: ERROR: Filesystem Info cache is empty, unable to calculate necessary parameters.

The problem is caused by the call to AutoExpire::Update(true) right at the beginning
of MainServer::MainServer() in file mythtv/programs/mythbackend/mainserver.cpp,
before the mainserver is passed to the expirer with expirer->SetMainServer(this).

The problem is solved by moving the call to AutoExpire::Update(true) to the end of
the function body, after the mainserver is passsed to the expirer.

Patch will be attached.
Patch is tested with trunk SVN 26882.

Attachments (2)

mainserver.cpp.patch (744 bytes) - added by klaas.de.waal@… 8 years ago.
autoexpire.2.diff (1.2 KB) - added by robertm 8 years ago.

Download all attachments as: .zip

Change History (6)

Changed 8 years ago by klaas.de.waal@…

Attachment: mainserver.cpp.patch added

comment:1 Changed 8 years ago by robertm

Component: MythTV - RecordingMythTV - General
Owner: changed from danielk to cpinkham
Status: newassigned

patch looks fine, but cpinkham will know for sure

Changed 8 years ago by robertm

Attachment: autoexpire.2.diff added

comment:2 Changed 8 years ago by robertm

(In [26911]) Prevent spurious and harmless error message complaining about autoexpire filesystem info cache by moving the first run of autoexpire to the end of the mainserver initialization. Based on patch by Klaas de waal, Refs #9113.

comment:3 Changed 8 years ago by robertm

Resolution: Fixed
Status: assignedclosed

(In [26912]) Backport r26911 from trunk to .24-fixes, fix harmless error on mainserver initialization, fixes #9113.

comment:4 Changed 8 years ago by robertm

Milestone: unknown0.24
Note: See TracTickets for help on using tickets.