Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#9122 closed defect (Fixed)

Cutlist editor skips fail

Reported by: robertm Owned by: markk
Priority: major Milestone: 0.24
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Relatively recent regression in the player/editor. Occurred sometime in the last week or so. To reproduce, load a recording, create a cutlist, and then remain in edit mode. Use the nextcut binding to jump to the beginning of a cut region. Change the skip distance to one second. Skip forward. You should skip forward one second. Instead, you skip to the end of the cut. Now attempt to skip backwards. Player may skip back to a black frame but will them obstinately refuse to skip backwards any further.

It seems that playback/skipping in the editor is obeying cutlists.

Attachments (1)

9122.patch (499 bytes) - added by Jim Stichnoth <stichnot@…> 9 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by robertm

Status: newassigned

Changed 9 years ago by Jim Stichnoth <stichnot@…>

Attachment: 9122.patch added

comment:2 Changed 9 years ago by Jim Stichnoth <stichnot@…>

It looks like even during editing, MythPlayer::EventLoop?() is checking deleteMap.TrackerWantsToJump?() and automatically advancing the current frame past a cut region. I have no idea how this change came about, but the attached patch at least works around by making TrackerWantsToJump?() return false during editing.

comment:3 Changed 8 years ago by robertm

(In [27054]) Fix cutlist editor thanks to diagnosis made by Jim Stichnoth but using a slightly different approach that more or less matches other spots in the MythPlayer? class. Don't honor cutlist when in edit mode. Seems to work okay here without any apparent regression. Refs #9122.

comment:4 Changed 8 years ago by robertm

Resolution: Fixed
Status: assignedclosed

(In [27055]) Merge r27054 from trunk into .24-fixes, backport Cutlist editor fix to ignore cut regions. Fixes #9122.

comment:5 Changed 8 years ago by sphery

(In [27106]) Set ffrew_seek to 0 when play_speed == 0. Refs #9122.

comment:6 Changed 8 years ago by sphery

(In [27107]) Set ffrew_seek to 0 when play_speed == 0. Refs #9122. Backports [27106] from trunk.

comment:7 Changed 8 years ago by chemobejk@…

Are you really sure this is fixed in all cases? For certain (older?) recordings the frontend gets stuck in the cut list editor reproducibly with 0.24. It just stops accepting any keyboard input and I have to kill & restart the frontend.

Things I checked already:

  • happens with vdpau, opengl & xv renderers
  • rebuild the jump index for the recording with mythcommflag --rebuild
  • cleared the commercial skip list for the recording with mythcommflag
  • transcoded the recording using Default (i.e. MPEG2-to-MPEG2)
  • No error in the frontend log (I checked with -v gui)
  • No load on the machine (so I don't think the frontend is busy looping)

I just have to go into such a recording, start the cut list editor and use UP/DOWN (skip interval) and/or LEFT/RIGHT (skip backward/forward) and it randomly, but reproducibly gets stuck after only a few key presses.

comment:8 Changed 8 years ago by chemobejk@…

I've now tracked my problem down with the debugger to an endless waiting loop in MythPlayer::WaitForSeek?(). See ticket #9263 for the details.

Note: See TracTickets for help on using tickets.