Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#9127 closed patch (Fixed)

[PATCH] mythbackend setverbose command line option parsing

Reported by: lvr@… Owned by:
Priority: minor Milestone: 0.24
Component: MythTV - General Version: Master Head
Severity: low Keywords: mythbackend setverbose
Cc: Ticket locked: no

Description

Passing a valid --setverbose option string to mythbackend results in an "Invalid argument" error exit. This prevents changing mythbackend's log detail after startup as a daemon.

The problem is with MythCommandLineParser::PreParse? in mythcommandlineparser.cpp which should return true when a valid option is detected. The attached patch fixes this.

Attachments (1)

mythclp.diff (515 bytes) - added by lvr@… 9 years ago.
mythbackend setverbose option fix

Download all attachments as: .zip

Change History (4)

Changed 9 years ago by lvr@…

Attachment: mythclp.diff added

mythbackend setverbose option fix

comment:1 Changed 9 years ago by robertm

(In [26913]) Fix obvious missing return value in mythcommandlineparser pointed out by lvr at softsystem. Refs #9127.

comment:2 Changed 9 years ago by robertm

Resolution: Fixed
Status: newclosed

(In [26914]) Backport r26913 from trunk to .24-fixes, fix return value in --setverbose in mythcommandlineparser. Fixes #9127.

comment:3 Changed 9 years ago by robertm

Milestone: unknown0.24
Note: See TracTickets for help on using tickets.