Opened 9 years ago

Closed 9 years ago

#9145 closed patch (Duplicate)

[PATCH] Mythmusic: white noise on startup or pause if using PulseAudio

Reported by: Lawrence Rust <lvr@…> Owned by: JYA
Priority: major Milestone: unknown
Component: MythTV - Audio Output Version: Master Head
Severity: high Keywords: pulse audio pause noise
Cc: Ticket locked: no

Description

If I configure the default audio device to be PulseAudio:default then when I start Mythmusic I often hear just white noise. If I press pause/play several times the noise stops and the music is correctly played. The noise doesn't appear to affect OSS or ALSA.

The problem appears to be with pause handling in AudioOutputBase::OutputAudioLoop?. The attached patch fixes this.

Attachments (1)

pause.diff (999 bytes) - added by Lawrence Rust <lvr@…> 9 years ago.
Fix PulseAudio? startup noise

Download all attachments as: .zip

Change History (2)

Changed 9 years ago by Lawrence Rust <lvr@…>

Attachment: pause.diff added

Fix PulseAudio? startup noise

comment:1 Changed 9 years ago by JYA

Resolution: Duplicate
Status: newclosed

Interesting it seems to fix the white noise for pulse, at least this gives a direction to look into. But that fix will break more things than it fixes and will be the source of a lot of buffer underruns ; you need to continually feed the audio card while it's opened.

Duplicate of #8894

Note: See TracTickets for help on using tickets.