Opened 9 years ago

Closed 9 years ago

#9161 closed defect (Duplicate)

changing to the wrong channel when browsing in live tv (with more than one tuner)

Reported by: Simon Kenyon <simon@…> Owned by: Janne Grunau
Priority: minor Milestone: unknown
Component: MythTV - Video Playback Version: Master Head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

i have just built my backends and frontends with trunk #27043 i have two backends with two tuners on each

if i change channel in livetv by specifying the channel number it changes correctly. but it does not seem to know which tuner it is using. if i then change channel with CHANNELUP/CHANNELDOWN, it picks the wrong tuner.

i have attached a full, annotated log from by frontend

build details are:

Path: .
URL: http://cvs.mythtv.org/svn/trunk
Repository Root: http://cvs.mythtv.org/svn
Repository UUID: 7dbf422c-18fa-0310-86e9-fd20926502f2
Revision: 27043
Node Kind: directory
Schedule: normal
Last Changed Author: wagnerrp
Last Changed Rev: 27042
Last Changed Date: 2010-10-29 17:54:50 +0100 (Fri, 29 Oct 2010)

all machines are AMD64 running gentoo linux

Attachments (2)

change-channel.log (16.4 KB) - added by Simon Kenyon <simon@…> 9 years ago.
log from frontend
9161.log (7.2 KB) - added by Simon Kenyon <simon@…> 9 years ago.
sql errors in the log after applying 6948-v2.patch

Download all attachments as: .zip

Change History (7)

Changed 9 years ago by Simon Kenyon <simon@…>

Attachment: change-channel.log added

log from frontend

comment:1 Changed 9 years ago by beirdo

Component: MythTV - GeneralMythTV - Video Playback
Owner: set to Janne Grunau

comment:2 Changed 9 years ago by beirdo

Status: newassigned

comment:3 Changed 9 years ago by Simon Kenyon <simon@…>

i think this is a duplicate of #9137.

Changed 9 years ago by Simon Kenyon <simon@…>

Attachment: 9161.log added

sql errors in the log after applying 6948-v2.patch

comment:4 Changed 9 years ago by Simon Kenyon <simon@…>

just built trunk #24708 with 6948-v2.patch applied and the patch fixes this problem. seems that this is also a duplicate of #6948

however i did get a lot of errors in the log (attached)

comment:5 Changed 9 years ago by sphery

Resolution: Duplicate
Status: assignedclosed

Thanks for reporting back, Simon.

Note: See TracTickets for help on using tickets.