Opened 9 years ago

Closed 9 years ago

#9195 closed defect (Fixed)

Teletext does not clear from the screen until replaced

Reported by: mythtv@… Owned by: markk
Priority: minor Milestone: 0.24
Component: MythTV - Video Playback Version: 0.24-fixes
Severity: low Keywords:
Cc: Ticket locked: no

Description

This is a very minor issue, but an annoyance nonetheless.

I recently upgrade from 0.23-fixes to 0.24 fixes and I noticed that the teletext closed captioning is a little quirky now. The CC appears to be displaying correctly, but the most recent one that is displayed does not get cleared from the screen until the following CC is displayed. For example, if a CC is displayed, then the next one doesn't start for another 20 seconds, the last displayed CC will stay on the screen for 20 seconds. I'm not sure of the technical aspects of closed captioning, so I don't know if there is normally a default timeout or if the CC stream is supposed to send a signal that says to clear what is displayed. This is much more evident in movies, which can go an extended period of time without updating the CC text.

I never observed this behavior in 0.23-fixes.

Change History (6)

comment:1 Changed 9 years ago by markk

Milestone: unknown0.25
Owner: changed from Janne Grunau to markk
Status: newaccepted

I've just tested with a few samples I have here and teletext captions appear to be cleared at 'reasonable' times (before the next caption).

I'm going to need a sample that clearly demonstrates the trailing subtitles and an indication (as verified from an alternative player/set top box/tv) of how long you think they should be displayed for.

comment:2 Changed 9 years ago by markk

Status: acceptedinfoneeded

comment:3 Changed 9 years ago by mythtv@…

I'm trying to figure out the best way to provide a sample. I have a recording of "Anacondas: Trail of Blood" that exhibits the problem. For example, there's a part that says "[metal rattling]" that appears and doesn't go away for about 20-30 seconds. The appears that only reason it goes away is because it is swapped with the next caption. The entire clip is 4.4GB, so I obviously can't post it somewhere.

I just did some quick searching and now realize I may have mislabeled this. I was under the (false) impression that teletext and closed captioning were the same thing, but it looks like teletext is actually a European standard for PAL video streams while closed captioning is used in North America. This ticket is actually referring to closed captioning in a NTSC video stream.

Do you know of a way to re-encode the video stream and maintain that data? I found some information on the wiki that showed how to use CCExtractor to extract the closed captions to a text file. I did this and found the following entries:

00:09:27,567 --> 00:09:30,201

[metal rattling]

00:09:57,363 --> 00:09:59,664

[soft growling]

I assume this indicates the closed captioning is supposed to display for about three seconds, but it is actually displayed for about 30 seconds until the following subtitle is displayed. Let me know what else I can provide.

comment:4 Changed 9 years ago by anonymous

For analogue captions (CC 608), this issue was fixed a few days ago in r27124 - so you should update.

If you are using digital captions, please attach the full output of mythfrontend -v playback.

If you in doubt, just post the log!

comment:5 Changed 9 years ago by mythtv@…

I updated to the latest revision and it looks like the problem is resolved (I figured the change in r27124 might be related). Thanks for the fix!

comment:6 Changed 9 years ago by markk

Milestone: 0.250.24
Resolution: Fixed
Status: infoneededclosed

Thanks for feeding back.

Note: See TracTickets for help on using tickets.