Opened 9 years ago

Closed 8 years ago

#9245 closed Bug Report (Works for me)

LiveTV: No sound snd-hda-intel HDMI

Reported by: mark.faine@… Owned by: JYA
Priority: minor Milestone: unknown
Component: MythTV - Audio Output Version: 0.24
Severity: medium Keywords:
Cc: Ticket locked: no

Description

uname: Linux htpc.localdomain 2.6.35-23-generic #37-Ubuntu SMP Fri Nov 5 19:17:11 UTC 2010 i686 GNU/Linux Ubuntu Linux 10.10 Intel ION platform (Zotac MAG) Nvidia driver 260.19.21

Alsa 1.0.23 and PulseAudio? - audio works in every other tested application including mythvideo and recorded tv from before upgrade to 0.24

Error Message:

2010-11-17 18:05:00.967 Spawning LiveTV Recorder -- begin 2010-11-17 18:05:02.515 Spawning LiveTV Recorder -- end 2010-11-17 18:05:02.528 We have a playbackURL(/var/lib/mythtv/livetv/1050_20101117180501.nuv) & cardtype(DUMMY) 2010-11-17 18:05:02.528 We have a RingBuffer? 2010-11-17 18:05:02.593 AudioPlayer?: Disabling Audio, params(0,2,44100) 2010-11-17 18:05:02.800 Pulse: PulseAudio? suspend OK 2010-11-17 18:05:02.851 AudioOutput? Error: Aborting Audio Reconfigure. Invalid audio parameters ch 2 fmt 0 @ 44100Hz 2010-11-17 18:05:02.851 AudioPlayer?: Disabling Audio, reason is: Aborting Audio Reconfigure. Invalid audio parameters ch 2 fmt 0 @ 44100Hz 2010-11-17 18:05:02.851 playCtx, Error: Aborting Audio Reconfigure. Invalid audio parameters ch 2 fmt 0 @ 44100Hz

Tried every conceivable setting in Setup-General->Audio System to no avail.

Frontend and Backend logs are attached.

I don't know if it is related but I'm also experiencing bugs #9201 or 9177 (very similar bugs, may be duplicates)

Attachments (3)

mythfrontend.log (44.5 KB) - added by Mark Faine <mark.faine@…> 9 years ago.
Frontend Log
mythbackend.log (500.0 KB) - added by Mark Faine <mark.faine@…> 9 years ago.
Backend Log (abbreviated)
mythfrontend.2.log (20.3 KB) - added by Mark Faine <mark.faine@…> 9 years ago.
mythfrontend -v audio,playback

Download all attachments as: .zip

Change History (10)

Changed 9 years ago by Mark Faine <mark.faine@…>

Attachment: mythfrontend.log added

Frontend Log

Changed 9 years ago by Mark Faine <mark.faine@…>

Attachment: mythbackend.log added

Backend Log (abbreviated)

comment:1 Changed 9 years ago by JYA

Please provide audio with -v audio,playback those logs do not contain anything helpful.

The error "Aborting Audio Reconfigure. Invalid audio parameters ch 2 fmt 0 @ 44100Hz 2010-11-17 18:05:02.851 playCtx, Error: Aborting Audio Reconfigure. Invalid audio parameters ch 2 fmt 0 @ 44100Hz" is normal and expected when myth is started, this is not relevant to your playback issues.

Post the entire log.

Changed 9 years ago by Mark Faine <mark.faine@…>

Attachment: mythfrontend.2.log added

mythfrontend -v audio,playback

comment:2 Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

Status: newassigned

comment:3 Changed 9 years ago by anonymous

Could this have anything to do with it: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/579300 If not, forgive me but I thought it was worth mentioning.

comment:4 in reply to:  3 Changed 9 years ago by Mark Faine <mark.faine@…>

Replying to anonymous:

Could this have anything to do with it: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/579300 If not, forgive me but I thought it was worth mentioning.

I corrected my issue on the backend - switched audio from /dev/dsp1 to Alsa:default

comment:5 Changed 9 years ago by stuartm

Version: Unspecified0.24

comment:6 Changed 8 years ago by JYA

Status: assignedinfoneeded

Please update to the latest version of 0.24 ; and let us know if you still have issues

comment:7 Changed 8 years ago by JYA

Resolution: Works for me
Status: infoneededclosed

No news for 3 weeks. Assumed fix as I can't reproduce

Note: See TracTickets for help on using tickets.