Modify
Warning Please read the Ticket HowTo before creating or commenting on a ticket. Failure to do so may cause your ticket to be rejected or result in a slower response.

Opened 3 years ago

Closed 3 months ago

#9255 closed Bug Report (Fixed)

MythWeb not working (blank site)

Reported by: mirko2324@… Owned by: kormoc
Priority: minor Milestone: unknown
Component: Plugin - MythWeb Version: 0.24-fixes
Severity: medium Keywords:
Cc: Ticket locked: no

Description

OS: Xubuntu 10.10
MythTV-Version: 0.24-fixes Revision 27280


When I open the MythWeb page I get a blank site. In the apache error log there are the following entries:

[Wed Nov 17 20:15:19 2010] [error] [client 192.168.0.3] PHP Warning:  file_get_contents(modules_path/_shared/lang/English.lang): failed to open stream: No such file or directory in /usr/share/mythtv/mythweb/classes/Translate.php on line 168
[Wed Nov 17 20:15:19 2010] [error] [client 192.168.0.3] PHP Fatal error:  Failed to open translation file:  modules_path/_shared/lang/English.lang in /usr/share/mythtv/mythweb/classes/Translate.php on line 172

Workaround: Create a symbolic link for modules -> modules path (ln -s /usr/share/mythtv/mythweb/modules /usr/share/mythtv/mythweb/modules_path)

Attachments (0)

Change History (15)

comment:1 Changed 3 years ago by kenni

  • Status changed from new to assigned

5+ users have mentioned this issue on the -users list within the last few weeks, using different setups (Fedora, Ubuntu and Arch Linux), but without further information or a dev who is able to replicate this issue, it'll probably be hard to fix/workaround. Leaving it open for now.

comment:2 Changed 3 years ago by kenni

  • Milestone set to unknown

comment:3 Changed 3 years ago by anonymous

I used the fix at http://www.gossamer-threads.com/lists/mythtv/users/459835

Or more specifically, I entered ln -s /usr/share/mythtv/mythweb/modules /usr/share/mythtv/mythweb/modules_path

I'm using MythTV 0.24 on Mythbuntu 10.04.

comment:4 Changed 3 years ago by anonymous

Would moving defines.php farther up in includes/init.php fix this? I've moved mine under cleanup.php, and it works without using the workaround. I don't know the best place for defines.php in the init.php chain, however...

comment:5 Changed 3 years ago by anonymous

Maybe after session.php (so it doesn't break [24912]), but before translate.php?

comment:6 follow-up: Changed 3 years ago by anonymous

I also has the same issue. Fedora 12, fresh install from atrpms.

Moving defiles.php up under cleanup.php also fixed the issue for me.

MythTV Branch : branches/release-0-24-fixes

comment:7 in reply to: ↑ 6 Changed 3 years ago by ano@…

The error happened to me on debian/squeeze.
I tracked it to to the line "setting('WebPrefer_Channum', null, 1);" in mythweb/includes/db_update.php

comment:8 Changed 3 years ago by mdean

  • Status changed from assigned to infoneeded

Based on http://www.gossamer-threads.com/lists/mythtv/users/464638#464638 , it sounds like the problem may be due to using a too-old version of PHP. MythWeb now requires PHP 5.3.

Are any of the affected users using PHP 5.3? Can any affected users confirm that they are using an old PHP and that upgrading to PHP 5.3 fixes the issue?

comment:9 Changed 3 years ago by jcullen86@…

Using php5 5.3.3-1ubuntu9.1 and bug exists but is fix by workaround as described above

Running Ubuntu 10.10 and mythtv 0.24 autobuild

comment:10 Changed 3 years ago by mdean

  • Status changed from infoneeded to assigned

comment:11 Changed 3 years ago by kormoc

  • Resolution set to Fixed
  • Status changed from assigned to closed

Should be fixed in master 7cb9061 fixes/0.24 1a998aa

comment:12 Changed 5 months ago by code.mythtv.org@…

  • Resolution Fixed deleted
  • Status changed from closed to new

This issue (or one very much like it) just occurred for me. I am using mythbuntu 12.04, with mythtv 0.25. I have just upgraded to mythtv 0.26 and this error has occurred.

That is, I attempt to access the web interface and I get the following page served:

Warning at /usr/share/mythtv/mythweb/modules/_shared/tmpl/default/header.php, line 12:
!!NoTrans: Cannot modify header information - headers already sent by (output started at /usr/share/mythtv/mythweb/modules/_shared/tmpl/default/header.php:13)!!

In the apache access log I get:

PHP Warning:  Failed to open translation file:  modules_path/_shared/lang/English.lang in /usr/share/mythtv/mythweb/classes/Translate.php on line 173,

This looks like the same issue as was reported here, so I have re-opened this ticket on the basis that there has been a regression in mythtv 0.26 (or at least the mythbuntu packaging thereof).

comment:13 Changed 5 months ago by code.mythtv.org@…

Addendum to the above: this is with PHP 5.3.10-1ubuntu3.8

comment:14 Changed 5 months ago by code.mythtv.org@…

Suspect mythbuntu packaging partially to blame as I solved it via the steps in http://www.gossamer-threads.com/lists/mythtv/users/529915?do=post_view_threaded#529915

It looks like mythweb might be substituting an incorrect path when there are database issues.

comment:15 Changed 3 months ago by mdean

  • Resolution set to Fixed
  • Status changed from new to closed

If you find a new issue, please report it in a new bug. There's no benefit to recycling old bug reports.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'new'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.