Opened 9 years ago

Closed 9 years ago

#9293 closed Bug Report (Won't Fix)

No still images / menus when playing DVDs with XvMC-VLD

Reported by: Torsten Crass <torsten.crass@…> Owned by: markk
Priority: minor Milestone: 0.24.1
Component: MythTV - DVD Playback Version: 0.24
Severity: medium Keywords:
Cc: Ticket locked: no

Description

Running MythTV on a Via EPIA 10000 with Debian Sid, I observer the following symptoms when playing a DVD:

  • Still images (like "You are not allowed to show this DVD...blah...oil rigs...blah") not shown
  • Menus seem to work in principle, but only the menu entry highlights are shown, neither menu backgrounds nor menu pre/post animations are displayed

Used to work fine with 0.23-fixes.

Menus and stills are shown correctly when falling back to ffmpeg renderer.

Attachments (9)

mythfrontend-version.txt (739 bytes) - added by Torsten Crass <torsten.crass@…> 9 years ago.
mythfrontend.log (88.3 KB) - added by Torsten Crass <torsten.crass@…> 9 years ago.
Xorg.0.log (73.7 KB) - added by Torsten Crass <torsten.crass@…> 9 years ago.
xorg.conf (4.4 KB) - added by Torsten Crass <torsten.crass@…> 9 years ago.
Actually used ServerLayout? is "TV"
disable-xvmc-dvd.diff (717 bytes) - added by markk 9 years ago.
disable-xvmc-dvd.2.diff (717 bytes) - added by markk 9 years ago.
disable-xvmc-dvd-switching.diff (769 bytes) - added by markk 9 years ago.
mythfrontend-chromakey.log (165.2 KB) - added by torsten.crass@… 9 years ago.
Log-file when playing dvd on patched frontend using chromakey OSD renderer
mythfrontend-ia44.log.tar.gz (32.7 KB) - added by torsten.crass@… 9 years ago.
Log-file when playing dvd on patched frontend using IA44 OSD renderer

Download all attachments as: .zip

Change History (22)

Changed 9 years ago by Torsten Crass <torsten.crass@…>

Attachment: mythfrontend-version.txt added

Changed 9 years ago by Torsten Crass <torsten.crass@…>

Attachment: mythfrontend.log added

Changed 9 years ago by Torsten Crass <torsten.crass@…>

Attachment: Xorg.0.log added

Changed 9 years ago by Torsten Crass <torsten.crass@…>

Attachment: xorg.conf added

Actually used ServerLayout? is "TV"

comment:1 Changed 9 years ago by Kenni Lund [kenni a kelu dot dk]

Status: newassigned

I'm foreseeing a quick kill..

comment:2 Changed 9 years ago by Torsten Crass <torsten.crass@…>

A quick kill foreseeing you are? Then strong the force in you must be...

No, seriously, let me know if you need any further information, like version numbers of other software packages possibly involved (for instance, I'm running Debian's openchrome driver 1:0.2.904+svn827-1 with patches 1, 2a and 2b from http://www.openchrome.org/trac/ticket/342 [URL currently unavailable] applied), or if you want me to do further test runs under special conditions.

Regards --

tcrass

Changed 9 years ago by markk

Attachment: disable-xvmc-dvd.diff added

Changed 9 years ago by markk

Attachment: disable-xvmc-dvd.2.diff added

Changed 9 years ago by markk

comment:3 Changed 9 years ago by markk

Milestone: unknown0.24.1
Status: assignedaccepted

Torsten

I've attached 2 patches for testing, both against fixes/0.24

disable-xvmc-dvd-switching.diff - this disables a workaround that was in place for dvd playback when using XvMC. This may help and if so it is the preferred solution.

disable-xvmc-dvd.diff - this just ensures xvmc is not used for dvd playback (but will still be used for all other media). If all else fails I will apply this.

thanks, Mark

comment:4 Changed 9 years ago by markk

Status: acceptedinfoneeded

comment:5 Changed 9 years ago by quimax@…

Same issue with NVidia (pre-vdpau) hardware. Using the ffmpeg/opengl cures the issue for me.

comment:6 Changed 9 years ago by robertm

Rather than a me too, which we specifically ask you not to add in our ticket howto, why not try testing the patches?

comment:7 Changed 9 years ago by quimax@…

I don't want to be "a me-too" person. I thought it would be a good bit of information to know it doesn't just affect the openchrome VIA chip the problem was originally posted with.

I was going to try the patches as well, however, my system actually works *better* with the ffmpeg/opengl setup. Sorry for 'cluttering' the ticket system, I'll cease trying to be helpful by providing more information unless I know it's exactly what's wanted.

comment:8 Changed 9 years ago by markk

Resolution: Fixed
Status: infoneededclosed

Following SHA 40df4b66c825e7148a44, XvMC is now disabled when playing DVDs in 0.24

XvMC has already gone in master and hence will not be available in 0.25.

comment:9 Changed 9 years ago by torsten.crass@…

Hi there,

I just realised that two mails I sent in reply to this ticket haven't reached this thread... So here's what I wrote on December 13th, 2010:


Mark,

I've attached 2 patches for testing, both against fixes/0.24

disable-xvmc-dvd-switching.diff - this disables a workaround that was in place for dvd playback when using XvMC. This may help and if so it is the preferred solution.

disable-xvmc-dvd.diff - this just ensures xvmc is not used for dvd playback (but will still be used for all other media). If all else fails I will apply this.

thanks a lot for the patch -- no idea when I will find the time to apply and test it, though (sick children around, plus the usual pre-christmas business). In particular since this would mean to switch my system back to "installation from source", rather than from debian multimedia packages, which I found to be much more convenient...

Anyway, thanks again, and I'll let you know the outcome of the test patch asap.

Regards --

Torsten


On December 19th I wrote another mail, this time containing actual test results from applying Mark's patches:


Mark,

hooray, already after applying patch #1 (disable-xvmc-dvd-switching.diff), the menus backgrounds are back, and so are the pre- and post-animations!

However, there is still a problem: Once drawn, menu highlights don't get cleared when a menu item gets de-selected -- they even stay when playing the actual movie! Do you think this is a related issue, or should I submit a new ticket?

Regards --

Torsten


If I understood patch #1 correctly, it would disable XvMC only when displaying still-image based DVD menus. This would definitely be the preferred solution rather than completely disabling XvMC for DVD playback, since the latter would give M10K-based Myth systems a really hard time (loads of stuttering during playback).

So would it be possible to re-open this bug and further discuss this issue?

Regards --

Torsten

comment:10 Changed 9 years ago by markk

Resolution: Fixed
Status: closednew

Torsten

Happy to find a better solution (though please bear in mind XvMC will definitely be gone in 0.25).

With the disable-xvmc-dvd-switching.diff applied, can you please check playback with the OSD renderer set to both chromakey and IA44 and confirm whether both fix the original issue and whether you see the new issue of buttons not disappearing.

Please attach the output of mythfrontend -v playback when using both OSDs.

Thanks, Mark

comment:11 Changed 9 years ago by markk

Status: newinfoneeded_new

comment:12 in reply to:  10 Changed 9 years ago by torsten.crass@…

Mark,

Replying to markk:

With the disable-xvmc-dvd-switching.diff applied, can you please check playback with the OSD renderer set to both chromakey and IA44 and confirm whether both fix the original issue and whether you see the new issue of buttons not disappearing.

just for the recor: the menu problems described above occured while using the chromakey renderer. When switching to IA44, menu items didn'd stay while the movie was playing, but there wasn't any highlighting, either. So none of two choices turned out really satisfactory. (Logs attached.)

But anyway...

(though please bear in mind XvMC will definitely be gone in 0.25).

...since this means I'll have to get a new mainboard sooner or later (without XvMC my poor, old M10K board does have a really hard time, leading to lots of video stuttering), at least for me the issue isn't that pressing anymore.

Regards --

Torsten

Changed 9 years ago by torsten.crass@…

Attachment: mythfrontend-chromakey.log added

Log-file when playing dvd on patched frontend using chromakey OSD renderer

Changed 9 years ago by torsten.crass@…

Log-file when playing dvd on patched frontend using IA44 OSD renderer

comment:13 Changed 9 years ago by markk

Resolution: Won't Fix
Status: infoneeded_newclosed

Torsten - thanks for the feedback. I'm going to close this as "won't fix" and leave fixes/0.24 in its current state (i.e. with dvd playback using software decoding). If anyone can come up with a working solution, I'll be happy to re-open and review it again.

Note: See TracTickets for help on using tickets.