Opened 9 years ago

Closed 9 years ago

#9302 closed Bug Report (Won't Fix)

svn27357 DolbyDigital2.0 isn't passed through

Reported by: tephra@… Owned by: JYA
Priority: trivial Milestone: unknown
Component: MythTV - Audio Output Version: Master Head
Severity: low Keywords:
Cc: Ticket locked: no

Description

Hi Dev's,

I know there have been a lot of changes to the pass through/sound interface recently.

For some reason DD2.0 isn't being passed raw to the sound device, DD5.1 is being passed through correctly.

I have DolbyDigital? and DTS passthrough ticked in the setup page, I also have the speaker configuration set to 5.1.

I have a nvidia 8300 GPU (which has a HDMI connector) I am using the HDMI audio digital device in mythtv.

Please let me know if you need anything futher! :)

Cheers David

Change History (1)

comment:1 Changed 9 years ago by JYA

Resolution: Won't Fix
Status: newclosed

This is by design.

You can't switch from passthrough to non-passthrough (e.g. decoded into PCM) on the fly which would be required to be able to enable audio upmixing.

Making 2.0 AC3 passthrough would prevent using upmixing on those streams.

Stereo content will always be decoded and passed as PCM either via analog or digital.

Their will be no audible differences between the two

Note: See TracTickets for help on using tickets.