Opened 14 years ago

Closed 14 years ago

#933 closed patch (fixed)

Fix deinterlacing getting turned ON for progressive scan channel after PAUSE in live-tv

Reported by: tralph11@… Owned by: danielk
Priority: minor Milestone: 0.19
Component: mythtv Version: head
Severity: medium Keywords:
Cc: Ticket locked: no

Description

The problem occurs only when pressing PAUSE for a progressive scan channel after an interlaced channel has been viewed. The problem is triggered if m_can_double is set to true when an interlaced channel is viewed but it isn't reset to false when a progressive channel is tuned. This caused DoPlay? to re-enable the deinterlacer after a PAUSE event. I found two places in NuppelVideoPlayer?.cpp that looks like m_can_double needs to be reset.

Consequently this only happens for live-tv.

Attachments (1)

progressive_deint_fix.diff (759 bytes) - added by tralph11@… 14 years ago.

Download all attachments as: .zip

Change History (4)

Changed 14 years ago by tralph11@…

Attachment: progressive_deint_fix.diff added

comment:1 Changed 14 years ago by anonymous

Version: head

comment:2 Changed 14 years ago by danielk

Milestone: 0.19
Owner: changed from Isaac Richards to danielk

comment:3 Changed 14 years ago by danielk

Resolution: fixed
Status: newclosed

(In [8515]) Fixes #933. References #904.

I didn't apply the patch as it changes the meaning of m_can_double. This fixes the problem by checking m_scan and m_DeintSetting before re-enabling deinterlacing.

Note: See TracTickets for help on using tickets.