Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#9387 closed Bug Report (fixed)

Mythfrontend segfaults

Reported by: otto@… Owned by: paulh
Priority: blocker Milestone: 0.25
Component: MythTV - General Version: Master Head
Severity: high Keywords:
Cc: Ticket locked: no

Description

I've started to see frontend segfaults in different places within last couple of days or week. Segfaults happen in MythNews?, MythBrowser? and in playback startup. There are couple of backtraces attached.

Attachments (5)

mythversion.txt (585 bytes) - added by otto@… 8 years ago.
mythnews-bt.txt (28.8 KB) - added by otto@… 8 years ago.
mythnews-bt2.txt (26.6 KB) - added by otto@… 8 years ago.
mythbrowser-bt.txt (15.7 KB) - added by otto@… 8 years ago.
playbackbox-bt.txt (54.7 KB) - added by otto@… 8 years ago.

Download all attachments as: .zip

Change History (11)

Changed 8 years ago by otto@…

Attachment: mythversion.txt added

Changed 8 years ago by otto@…

Attachment: mythnews-bt.txt added

Changed 8 years ago by otto@…

Attachment: mythnews-bt2.txt added

Changed 8 years ago by otto@…

Attachment: mythbrowser-bt.txt added

comment:1 Changed 8 years ago by otto@…

Another crash happened (bt attached) and now within Watch Recordings -screen. It looks from the backtraces that it's always related to MythCoreContext? / MythObservable? / sending events, even though happening in lots of places and screens.

Changed 8 years ago by otto@…

Attachment: playbackbox-bt.txt added

comment:2 Changed 8 years ago by beirdo

Your version info indicates that you have custom patches in your tree.

1) please use unpatched source from git and test again

2) please be sure to "make distclean" before compiling. There have been several API changes recently.

Last edited 8 years ago by beirdo (previous) (diff)

comment:3 Changed 8 years ago by stuartm

Milestone: unknown0.25
Owner: set to beirdo
Priority: minorblocker
Severity: mediumhigh
Status: newassigned

Gavin, I can confirm this bug so we don't need Otto to follow those steps this time.

For me it seems to be directly related to the browser widget. e.g. Shortly after viewing the program details screen the frontend crashes. There is enough of a lag that it can appear that the trigger was another action which might explain Otto seeing the problem on starting playback. The mythnews/mythbrowser links are obvious. This doesn't mean that it's the browser itself, but something has changed recently that causes events originating from this widget to trigger a segfault.

comment:4 Changed 8 years ago by stuartm

Owner: changed from beirdo to paulh

comment:5 Changed 8 years ago by paulh

Resolution: Fixed
Status: assignedclosed

In ([444c43f3b])

Fix a seg fault caused by not removing the BrowserApi? from the list of listeners when its destructed.

Fixes ticket 9387.

comment:6 Changed 8 years ago by Paul Harrison

Resolution: Fixedfixed

Fix a seg fault caused by not removing the BrowserApi? from the list of listeners when its destructed.

Fixes ticket 9387.

Changeset: 444c43f3be201bc347e856039422f35677747a5b

Note: See TracTickets for help on using tickets.