Opened 7 years ago

Closed 7 years ago

#9390 closed Bug Report (Works for me)

DAYLEFT / DAYRIGHT key bindings do not work with PgUp and PgDown in Program Guide

Reported by: confirm@… Owned by: sphery
Priority: minor Milestone: unknown
Component: MythTV - General Version: 0.23.1
Severity: low Keywords:
Cc: Ticket locked: no

Description

Hello, previous versions I've had my PgUp? and PgDown? keys bound to these two functions - DAYLEFT and DAYRIGHT - and it worked. My Program Guide would skip backwards or forwards exactly one day when these keys were pressed.

Unfortunately, in this current version, the Guide simply goes up or down (presumably by a page) instead...

I can bind other keys to these functions and it does appear to work but there seems to be some magic override somewhere that I cannot find which does not allow me to use PgUp? and PgDown? - which refuse to do anything but make the Guide go up and down (presumably by a page) instead of left and right.

Change History (2)

comment:1 Changed 7 years ago by sphery

Component: MythTV - Mythtv-setupMythTV - General
Owner: changed from danielk to sphery
Status: newassigned
Type: Patch - FeatureBug Report

comment:2 Changed 7 years ago by sphery

Resolution: Works for me
Status: assignedclosed

I was unable to reproduce this behavior on 0.23-fixes or trunk (didn't test 0.24-fixes, but since the ticket was filed against 0.23.1...). Please check your key list for TV Frontend/DAYLEFT and DAYRIGHT actions in mythfrontend Utilities/Setup?|Edit Keys, and set them as desired. Also, please verify that you do not have conflicting keys in the keylists for TV Frontend/PAGEUP, PAGEDOWN, PAGELEFT and/or PAGERIGHT actions (note that TV Frontend/PAGEUP and PAGEDOWN do not exist in 0.24+, and a conflicting key in Global/PAGEUP or PAGEDOWN will not cause problems).

If you still see the behavior you've mentioned, please reply to this message on the mailing list (either mythtv-users or mythtv-dev) with the output of:

SELECT context, action, keylist FROM keybindings WHERE context IN ('TV Frontend', 'Global')\G

Thanks.

Note: See TracTickets for help on using tickets.